meta-ibm: move all meta-witherspoon metadata

The metadata common to all IBM systems is confusingly split between
meta-ibm and meta-witherspoon.  Move everything to meta-ibm.

The meta-ibm README is re-written to more accurately reflect the scope
of the layer.

Allow the configuration samples (bblayers.conf.sample,
local.conf.sample) to be sourced from either meta-ibm or
meta-witherspoon until such a time that any workflows and tooling have
had the opportunity to move to meta-ibm.

(From meta-ibm rev: 6e05ef2e90b214eaf4e43ee7027bbbb1d8d09442)

Change-Id: I3ec890d5300f9649c974ea6b9dca93a2e8a889ab
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-ibm/recipes-phosphor/bmcweb/bmcweb_%.bbappend b/meta-ibm/recipes-phosphor/bmcweb/bmcweb_%.bbappend
index 44f4f46..8e4049e 100644
--- a/meta-ibm/recipes-phosphor/bmcweb/bmcweb_%.bbappend
+++ b/meta-ibm/recipes-phosphor/bmcweb/bmcweb_%.bbappend
@@ -1,3 +1,8 @@
 EXTRA_OECMAKE_append = " \
     -DBMCWEB_INSECURE_ENABLE_REDFISH_FW_TFTP_UPDATE=ON \
 "
+
+inherit obmc-phosphor-discovery-service
+
+REGISTERED_SERVICES_${PN} += "obmc_redfish:tcp:443:"
+REGISTERED_SERVICES_${PN} += "obmc_rest:tcp:443:"