phosphor-software-manager: Add synclist

Create a synclist file to specify the files and directories
that the sync manager should copy over to the alternate
BMC chip. Store the synclist file in /etc/ by default so
that it can be modified at runtime if desired.

Change-Id: I458b08fafd565e7622a1c7497b6d9c5b61674fdc
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/flash/phosphor-software-manager.bb b/meta-phosphor/common/recipes-phosphor/flash/phosphor-software-manager.bb
index 746daeb..ba3399c 100644
--- a/meta-phosphor/common/recipes-phosphor/flash/phosphor-software-manager.bb
+++ b/meta-phosphor/common/recipes-phosphor/flash/phosphor-software-manager.bb
@@ -71,7 +71,10 @@
     ${sbindir}/obmc-flash-bmc \
     /usr/local \
     "
-FILES_${PN}-sync += "${sbindir}/phosphor-sync-software-manager"
+FILES_${PN}-sync += " \
+    ${sbindir}/phosphor-sync-software-manager \
+    ${sysconfdir}/synclist \
+    "
 DBUS_SERVICE_${PN}-version += "xyz.openbmc_project.Software.Version.service"
 DBUS_SERVICE_${PN}-download-mgr += "xyz.openbmc_project.Software.Download.service"
 DBUS_SERVICE_${PN}-updater += "xyz.openbmc_project.Software.BMC.Updater.service"
@@ -103,10 +106,16 @@
 SYSTEMD_SUBSTITUTIONS += "RW_SIZE:${BMC_RW_SIZE}:obmc-flash-bmc-ubirw.service"
 
 SRC_URI += "file://obmc-flash-bmc"
+SRC_URI += "file://synclist"
 do_install_append() {
     install -d ${D}${sbindir}
     install -m 0755 ${WORKDIR}/obmc-flash-bmc ${D}${sbindir}/obmc-flash-bmc
     install -d ${D}/usr/local
+
+    if [ -f ${WORKDIR}/build/phosphor-sync-software-manager ]; then
+        install -d ${D}${sysconfdir}
+        install -m 0644 ${WORKDIR}/synclist ${D}${sysconfdir}/synclist
+    fi
 }
 
 SRC_URI += "git://github.com/openbmc/phosphor-bmc-code-mgmt"