meta-openembedded: subtree update:17fd382f34..679bb49126

Andreas Müller (9):
      gparted: upgrade 0.33.0 -> 1.1.0
      gjs: 1.58.6 -> 1.58.7
      nautilus: upgrade 3.34.2 -> 3.34.3
      xfce4-whiskermenu-plugin: upgrade 2.4.3 -> 2.4.4
      xfce4-panel: upgrade 4.14.3 -> 4.14.4
      poppler: upgrade 0.86.1 -> 0.88.0
      mutter: upgrade 3.34.5 -> 3.34.6
      openvpn: upgrade 2.4.8 -> 2.4.9
      file-roller: upgrade 3.32.4 -> 3.32.5

Honggyu Kim (1):
      uftrace: update commit hash to more robust version

Khem Raj (6):
      luajit: Disable on rv32
      abseil-cpp: Fix build on riscv32
      rsyslog: Enable atomic builtins on rv32
      python3-grpcio: Fix build with riscv32
      waf: Add cross answers for riscv32
      libnma: Fix build on riscv32

Mingli Yu (1):
      nss: enable uint128 support on mips64

Peter Kjellerstedt (2):
      samba: Remove the dependency on libbsd
      paho-mqtt-c: Update to the real 1.3.2, and correct the license

Slater, Joseph (1):
      syslog-ng: change shebang to python3

Trevor Gamblin (2):
      python3-atomicwrites: add python3-misc to RDEPENDS
      python3-pysocks: add python3-logging to RDEPENDS

zhengruoqin (4):
      python3-pytoml: Modify ptest output format
      python3-pytz: Modify ptest output format
      python3-scrypt: Modify ptest output format
      python3-serpent: Modify ptest output format

Change-Id: I7f985b3e43196dfe5064a954a12411ab6debdb68
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-openembedded/meta-oe/recipes-support/poppler/poppler_0.88.0.bb b/meta-openembedded/meta-oe/recipes-support/poppler/poppler_0.88.0.bb
new file mode 100644
index 0000000..d6a27f9
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/poppler/poppler_0.88.0.bb
@@ -0,0 +1,52 @@
+SUMMARY = "Poppler is a PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE = "https://poppler.freedesktop.org/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.xz \
+           file://0001-Do-not-overwrite-all-our-build-flags.patch \
+           file://basename-include.patch \
+           "
+SRC_URI[md5sum] = "d9aafddce4c079c9ebc7405e42ac25ba"
+SRC_URI[sha256sum] = "b4453804e9a5a519e6ceee0ac8f5efc229e3b0bf70419263c239124474d256c7"
+
+DEPENDS = "fontconfig zlib cairo lcms glib-2.0"
+
+inherit cmake pkgconfig gobject-introspection
+
+PACKAGECONFIG ??= "jpeg openjpeg png tiff nss splash"
+PACKAGECONFIG[jpeg] = "-DWITH_JPEG=ON -DENABLE_DCTDECODER=libjpeg,-DWITH_JPEG=OFF -DENABLE_DCTDECODER=none,jpeg"
+PACKAGECONFIG[png] = "-DWITH_PNG=ON,-DWITH_PNG=OFF,libpng"
+PACKAGECONFIG[tiff] = "-DWITH_TIFF=ON,-DWITH_TIFF=OFF,tiff"
+PACKAGECONFIG[curl] = "-DENABLE_LIBCURL=ON,-DENABLE_LIBCURL=OFF,curl"
+PACKAGECONFIG[openjpeg] = "-DENABLE_LIBOPENJPEG=openjpeg2,-DENABLE_LIBOPENJPEG=none,openjpeg"
+PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON,-DENABLE_QT5=OFF,qtbase qttools-native"
+PACKAGECONFIG[nss] = "-DWITH_NSS3=ON,-DWITH_NSS3=OFF,nss"
+PACKAGECONFIG[splash] = "-DENABLE_SPLASH=ON,-DENABLE_SPLASH=OFF,boost"
+
+# surprise - did not expect this to work :)
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'cmake_qt5', '', d)}
+
+SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
+
+EXTRA_OECMAKE += " \
+    -DENABLE_CMS=lcms2 \
+    -DENABLE_UNSTABLE_API_ABI_HEADERS=ON \
+    -DBUILD_GTK_TESTS=OFF \
+    -DENABLE_ZLIB=ON \
+    -DCMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES:PATH='${STAGING_INCDIR}' \
+    ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_GOBJECT_INTROSPECTION=ON', '-DENABLE_GOBJECT_INTROSPECTION=OFF', d)} \
+"
+
+do_configure_append() {
+    # poppler macro uses pkg-config to check for g-ir runtimes. Something
+    # makes them point to /usr/bin. Align them to sysroot - that's where the
+    # gir-wrappers are:
+    sed -i 's: ${bindir}/g-ir: ${STAGING_BINDIR}/g-ir:' ${B}/build.ninja
+}
+
+PACKAGES =+ "libpoppler libpoppler-glib"
+FILES_libpoppler = "${libdir}/libpoppler.so.*"
+FILES_libpoppler-glib = "${libdir}/libpoppler-glib.so.*"
+
+RDEPENDS_libpoppler = "poppler-data"