openpower-software-manager: Move ubiattach and ubiformat to single script

The service files that manage the pnor ubi volumes and mount points are
starting to get too much logic in them. Create a single shell script
instead of having all the commands and logic in the service files.

Also specify the ubi device number in ubiattach via the -d parameter
so that it matches the pnor mtd device number. In that way we always
know what the ubi device for pnor is, for when the bmc chip is formatted
with ubi we can differentiate them.

Remove the ExecStop entry on the service file, no need to detach the
volume when any service file stops.

Change-Id: Ib41592ea40ef8e58602100bb3ab51c5f4faada18
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb
index fa4a20f..28949a8 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb
@@ -28,16 +28,13 @@
 
 SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
 
-SRC_URI += " \
-        file://bios-ubiattach \
-        file://bios-ubiformat"
+SRC_URI += "file://obmc-flash-bios"
 
 SRCREV = "a8eda56300d309cb11566787d70fd1b9a5721e07"
 
 do_install_append() {
         install -d ${D}${sbindir}
-        install -m 0755 ${WORKDIR}/bios-ubiattach ${D}${sbindir}/bios-ubiattach
-        install -m 0755 ${WORKDIR}/bios-ubiformat ${D}${sbindir}/bios-ubiformat
+        install -m 0755 ${WORKDIR}/obmc-flash-bios ${D}${sbindir}/obmc-flash-bios
 }
 
 DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"