Add recipe for sdbusplus

Change-Id: I34876dd7540c73492a98bf6bf48e15a9ada89e45
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-extended/sdbusplus/sdbusplus.bb b/meta-phosphor/common/recipes-extended/sdbusplus/sdbusplus.bb
new file mode 100644
index 0000000..13222e9
--- /dev/null
+++ b/meta-phosphor/common/recipes-extended/sdbusplus/sdbusplus.bb
@@ -0,0 +1,36 @@
+SUMMARY = "C++ bindings for systemd dbus APIs"
+DESCRIPTION = "C++ bindings for systemd dbus APIs."
+HOMEPAGE = "http://github.com/openbmc/sdbusplus"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit autotools pkgconfig
+inherit pythonnative
+
+FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
+
+DEPENDS += "autoconf-archive-native"
+RDEPENDS_${PN} += " \
+        python-inflection \
+        python-mako \
+        python-pyyaml \
+        "
+
+SRC_URI += "git://github.com/openbmc/sdbusplus"
+SRCREV = "ccacc4af969a70cc24f84981b5a5dde01a928d09"
+
+PACKAGECONFIG ??= "libsdbusplus"
+PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
+
+S = "${WORKDIR}/git"
+
+PACKAGECONFIG_remove_class-native = "libsdbusplus"
+PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus"
+
+export BUILD_SYS
+export HOST_SYS
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+BBCLASSEXTEND += "native nativesdk"