systemd: pick upstream fixes for timedated

There are several fixes related to systemd/systemd#11420, which affects
openbmc/openbmc#3459

Pick the related changes to fix the issue.
Partially resolves openbmc/openbmc#3459.

Tested: Run below script to make sure setting time eventually succeeds.

    timedatectl set-ntp 1
    sleep 10  # Wait for a while for NTP service to start
    timedatectl set-ntp 0

    until busctl call org.freedesktop.timedate1 /org/freedesktop/timedate1 org.freedesktop.timedate1 SetTime xbb 1487304700000000 0 0
    do
      echo "Try again..."
    done

(From meta-phosphor rev: 076771ae7363a3342fe45f7f8f6b383811c8677e)

Change-Id: I453cff9224721052a1ed000fa4ded1d4858dcde1
Signed-off-by: Lei YU <mine260309@gmail.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
index 0d04f28..680f4f6 100644
--- a/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-phosphor/recipes-core/systemd/systemd_%.bbappend
@@ -14,6 +14,11 @@
 SRC_URI += "file://0002-networkd-Use-only-a-generic-CONFIGURING-state.patch"
 SRC_URI += "file://0003-networkd-Static-neighbor-support.patch"
 
+# Fixes from upstream for openbmc/openbmc#3459
+SRC_URI += "file://0001-timedate-defer-the-property-changed-signal-until-job.patch"
+SRC_URI += "file://0001-timedate-treat-activating-or-inactivating-NTP-client.patch"
+SRC_URI += "file://0002-timedate-refuse-to-set-time-when-previous-request-is.patch"
+
 RRECOMMENDS_${PN} += "obmc-targets"
 FILES_${PN} += "${systemd_unitdir}/network/default.network"