obmc-xmlpatch.bbclass: Use python3

Use python3native and remove a filter statement.

(From meta-phosphor rev: c55fc52815dcce6d2f5eeb77ed5a1aaafd990958)

Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Change-Id: Ic25919bc947b1733cfac0573a41f35a5f12ed194
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/classes/obmc-xmlpatch.bbclass b/meta-phosphor/classes/obmc-xmlpatch.bbclass
index 9dc3750..3598206 100644
--- a/meta-phosphor/classes/obmc-xmlpatch.bbclass
+++ b/meta-phosphor/classes/obmc-xmlpatch.bbclass
@@ -7,15 +7,15 @@
 #See patchxml.py for details on the XML patch format.
 #
 
-inherit pythonnative
+inherit python3native
 inherit obmc-phosphor-utils
 do_patch[depends] = "mrw-patch-native:do_populate_sysroot"
 
 
 def find_patch_files(d):
     all_patches = listvar_to_list(d, 'SRC_URI')
-    xml_patches = filter(lambda x: x.endswith('.patch.xml') and
-                         x.startswith('file://'), all_patches)
+    xml_patches = [x for x in all_patches if x.endswith('.patch.xml') and
+                         x.startswith('file://')]
 
     return [x.lstrip('file://') for x in xml_patches]