meta-phosphor: obmc-console: Use "[" instead of "[[" on recipe

"[[" is not supported on all shell types. dash for example.
So changing the "if" statement to use "[".

Tested on both bash and dash environment.

Signed-off-by: Vivekanand Veeracholan <vveerach@google.com>
Change-Id: I61f267d2c4bba054b6d1e2f1bff0ad3c6e833266
diff --git a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
index 6c8326e..40faead 100644
--- a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
+++ b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
@@ -51,7 +51,7 @@
         # If the OBMC_CONSOLE_TTYS variable is used without the default OBMC_CONSOLE_HOST_TTY
         # the port specific config file should be provided. If it is just OBMC_CONSOLE_HOST_TTY,
         # use the old style which supports both port specific or obmc-console.conf method.
-        if [[ "${OBMC_CONSOLE_TTYS}" !=  "${OBMC_CONSOLE_HOST_TTY}" ]]; then
+        if [ "${OBMC_CONSOLE_TTYS}" !=  "${OBMC_CONSOLE_HOST_TTY}" ]; then
                 rm -f ${D}${sysconfdir}/${BPN}/server.ttyVUART0.conf
 
                 for CONSOLE in ${OBMC_CONSOLE_TTYS}