meta-phosphor: change systemd.bbclass to match upstream override syntax

Upstream bbclasses changed to typically use the `:${PN}` override
syntax, including the SYSTEMD_ variables.  Change our systemd.bbclass
to do the same for consistency and perform a tree-wide variable
replacement.

Spot checked by building bletchley and witherspoon and checking
some of the SYSTEMD_LINK directives on installed packages under qemu.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I20a9dd809bff8af8759488734f80486c7228c6eb
diff --git a/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend b/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend
index 1401549..970b12c 100644
--- a/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend
+++ b/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend
@@ -1,5 +1,5 @@
 FILESEXTRAPATHS:append := ":${THISDIR}/${PN}"
 
 # Remove the override to keep service running after DC cycle
-SYSTEMD_OVERRIDE_${PN}:remove = "poweron.conf:phosphor-watchdog@poweron.service.d/poweron.conf"
+SYSTEMD_OVERRIDE:${PN}:remove = "poweron.conf:phosphor-watchdog@poweron.service.d/poweron.conf"
 SYSTEMD_SERVICE:${PN} = "phosphor-watchdog.service phosphor-watchdog-host-poweroff.service phosphor-watchdog-host-reset.service phosphor-watchdog-host-cycle.service"