meta-phosphor: change systemd.bbclass to match upstream override syntax

Upstream bbclasses changed to typically use the `:${PN}` override
syntax, including the SYSTEMD_ variables.  Change our systemd.bbclass
to do the same for consistency and perform a tree-wide variable
replacement.

Spot checked by building bletchley and witherspoon and checking
some of the SYSTEMD_LINK directives on installed packages under qemu.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I20a9dd809bff8af8759488734f80486c7228c6eb
diff --git a/meta-ibm/recipes-phosphor/chassis/vrm-control.bb b/meta-ibm/recipes-phosphor/chassis/vrm-control.bb
index 8a9ef7f..cc297d2 100644
--- a/meta-ibm/recipes-phosphor/chassis/vrm-control.bb
+++ b/meta-ibm/recipes-phosphor/chassis/vrm-control.bb
@@ -37,6 +37,6 @@
 
 SYSTEMD_SERVICE:${PN} += "${TMPL_ON_IRUNBIND} ${TMPL_ON_IRBIND}"
 SYSTEMD_SERVICE:${PN}:append:ibm-ac-server = " ${TMPL}"
-SYSTEMD_LINK_${PN}:append:ibm-ac-server = " ${@compose_list(d, 'FMT_ON', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_ON_IRBIND', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_ON_IRUNBIND', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN}:append:ibm-ac-server = " ${@compose_list(d, 'FMT_ON', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_ON_IRBIND', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_ON_IRUNBIND', 'OBMC_CHASSIS_INSTANCES')}"