meta-google: x86-power-control: use gbmc-psu-hardreset to reset chassis

This patch unifies the way to reset chassis for gBMC platforms. Note
that we can still customize this in the meta machine layer if needed.

Tested:
```
// from build dir:
cat tmp/work/*/x86-power-control/*/package/lib/systemd/system/chassis-system-reset.service
[Unit]
Description=System unit to hard reset or system reset chassis
Conflicts=xyz.openbmc_project.psusensor.service
Wants=gbmc-psu-hardreset.target

[Service]
Type=oneshot
RemainAfterExit=no
ExecStart=true

[Install]
WantedBy=chassis-system-reset.target

// scp the service files from build directory to bmc.
// From bmc:
bmc:~# systemctl start chassis-system-reset.service
bmc:~# Timeout, server xxx not responding.
```

Google-Bug-Id: 263450334
Signed-off-by: Tom Tung <tomtung@google.com>
Change-Id: I2c877324482afff0d41129db5d0340d44d9352d1
diff --git a/meta-google/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-google/recipes-x86/chassis/x86-power-control_%.bbappend
new file mode 100644
index 0000000..36d0138
--- /dev/null
+++ b/meta-google/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS:prepend:gbmc := "${THISDIR}/${PN}:"