debug: Avoid lighttpd build dependency

The debug tarball pulls in lmsensors, which attempts to pull in
lighttpd cgi support (for sensord cgi features) starting in Yocto
2.3.

Phosphor disables md4 support in openssl which lighttpd requires,
again - starting in Yocto 2.3.  Avoid this combination by removing
cgi support for sensord.

Tested: Built and verified Witherspoon image with QEMU
Change-Id: I4870f50f790c8b73d007f7fd89414e6724e21509
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-support/lm_sensors/lmsensors-config_1.0.bbappend b/meta-phosphor/common/recipes-support/lm_sensors/lmsensors-config_1.0.bbappend
new file mode 100644
index 0000000..83c9ea1
--- /dev/null
+++ b/meta-phosphor/common/recipes-support/lm_sensors/lmsensors-config_1.0.bbappend
@@ -0,0 +1,4 @@
+# Prevent lmsensors from pulling in lighttpd as lighttpd
+# uses md4 and we disable openssl md4 support.
+
+RRECOMMENDS_${PN}-cgi_remove = "lighttpd lighttpd-module-cgi"