meta-fii: meta-mori: Remove multi-user require of obmc-host-reset target

Rebooting the host will stop multi-user.target from reaching an active
state if obmc-host-reboot@0.target is called before then. As a result,
the BMC state will always be set to NotReady.

Testing:
Calling obmc-host-reboot@0.target prior to multi-user.target being
reached will no longer cause multi-user.target to fail.

Change-Id: Ie0e8fc5341472a930f9ec6f0bf74c9a2b2687d32
Signed-off-by: Kyle Nieman <kyle.nieman@fii-na.com>
diff --git a/meta-fii/meta-mori/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-fii/meta-mori/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index c351919..2f05677 100644
--- a/meta-fii/meta-mori/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-fii/meta-mori/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -39,4 +39,5 @@
     rm "$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service"
     rm "$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/obmc-host-stop@0.target"
     rm "$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/phosphor-reboot-host@0.service"
+    rm "$D$systemd_system_unitdir/multi-user.target.requires/obmc-host-reset@0.target"
 }