subtree updates:raspberrypi:arm:security: Jan 27 2023

meta-raspberrypi: 896566aa92..6c57b92708:
  Martin Jansa (2):
        pi-bluetooth: fix typo in Upstream-Status
        gstreamer1.0-omx: fix Upstream-Status format

meta-arm: 5c42f084f7..3d51e1117d:
  Abdellatif El Khlifi (1):
        arm-bsp/u-boot: Corstone1000: bump to v2022.10

  Anton Antonov (1):
        arm/kernel: Update ARM-FFA kernel drivers

  Daniel Díaz (1):
        arm-bsp/firmware-image-juno: Fix deployment of compressed Image

  Jon Mason (8):
        arm-bsp/juno: move to compressed initramfs image
        arm-bsp/juno: Update kernel patches to the latest
        arm-bsp/trusted-firmware-m: corstone1000: TFM file clean-ups
        arm/trusted-firmware-m: disable fatal warnings
        arm-toolchain: update Arm GCC to 12.2
        external-arm-toolchain: Enable 12.2.rel1 support
        arm-bsp: add u-boot v2022.10 support
        arm-bsp: add u-boot v2022.10 support

  Peter Hoyes (8):
        arm/scp-firmware: Ensure CMAKE_BUILD_TYPE is capitalized
        arm/scp-firmware: Disable cppcheck
        arm: Add addpylib declaration
        arm/lib: Add XAUTHORITY to runfvp environment
        classes: Define FVP_ENV_PASSTHROUGH variable dependencies
        classes: Prevent passing None to the runfvp environment
        classes: Set ARMLMD_LICENSE_FILE in the runfvp environment
        arm: Use SRC* variables consistently

  Qi Feng (1):
        arm-bsp/fvp-baser-aemv8r64: Rebase u-boot patches onto v2022.10

  Ross Burton (9):
        meta-*: mark layers as compatible with mickledore only
        arm-toolchain: remove obsolete oe_import
        CI: switch back to master
        CI: remove obsolete linux-yocto workarounds
        Revert "CI: revert a meta-clang change which breaks pixman (thus, xserver)"
        arm-bsp/fvp-base*: no need to remove rng-tools from openssh
        CI: pass --update and --force-checkout to kas in pending-updates job
        CI: use 'kas dump' instead of manually catting files
        CI: remove obsolete install

  Rui Miguel Silva (1):
        arm-bsp/u-boot: corstone500: bump to 2022.10

  Theodore A. Roth (1):
        arm/optee-os: Fix FILESEXTRAPATHS

meta-security: f991b20f56..3d9dab6d14:
  Chen Qi (1):
        openscap: add libpcre DEPEDNS to fix do_configure failure

  Markus Volk (1):
        bubblewrap: remove recipe

  Martin Jansa (1):
        layer.conf: update LAYERSERIES_COMPAT for mickledore

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I5abd2487fbf395b33b1934ff90bd6d97c7953e6c
diff --git a/meta-arm/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.7.0.bb b/meta-arm/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.7.0.bb
index 3b4469d..b4a4c41 100644
--- a/meta-arm/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.7.0.bb
+++ b/meta-arm/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.7.0.bb
@@ -15,11 +15,17 @@
                     file://../mbedtls/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
                     file://../mcuboot/LICENSE;md5=b6ee33f1d12a5e6ee3de1e82fb51eeb8"
 
-SRC_URI  = "git://git.trustedfirmware.org/TF-M/trusted-firmware-m.git;protocol=https;branch=${SRCBRANCH_tfm};name=tfm;destsuffix=git/tfm \
-            git://git.trustedfirmware.org/TF-M/tf-m-tests.git;protocol=https;branch=${SRCBRANCH_tfm-tests};name=tfm-tests;destsuffix=git/tf-m-tests \
-            git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=${SRCBRANCH_mbedtls};name=mbedtls;destsuffix=git/mbedtls \
-            git://github.com/mcu-tools/mcuboot.git;protocol=https;branch=${SRCBRANCH_mcuboot};name=mcuboot;destsuffix=git/mcuboot \
-            git://github.com/laurencelundblade/QCBOR.git;protocol=https;branch=${SRCBRANCH_qcbor};name=qcbor;destsuffix=git/qcbor \
+SRC_URI_TRUSTED_FIRMWARE_M ?= "git://git.trustedfirmware.org/TF-M/trusted-firmware-m.git;protocol=https"
+SRC_URI_TRUSTED_FIRMWARE_M_TESTS ?= "git://git.trustedfirmware.org/TF-M/tf-m-tests.git;protocol=https"
+SRC_URI_TRUSTED_FIRMWARE_M_MBEDTLS ?= "git://github.com/ARMmbed/mbedtls.git;protocol=https"
+SRC_URI_TRUSTED_FIRMWARE_M_MCUBOOT ?= "git://github.com/mcu-tools/mcuboot.git;protocol=https"
+SRC_URI_TRUSTED_FIRMWARE_M_QCBOR ?= "git://github.com/laurencelundblade/QCBOR.git;protocol=https"
+SRC_URI  = "${SRC_URI_TRUSTED_FIRMWARE_M};branch=${SRCBRANCH_tfm};name=tfm;destsuffix=git/tfm \
+            ${SRC_URI_TRUSTED_FIRMWARE_M_TESTS};branch=${SRCBRANCH_tfm-tests};name=tfm-tests;destsuffix=git/tf-m-tests \
+            ${SRC_URI_TRUSTED_FIRMWARE_M_MBEDTLS};branch=${SRCBRANCH_mbedtls};name=mbedtls;destsuffix=git/mbedtls \
+            ${SRC_URI_TRUSTED_FIRMWARE_M_MCUBOOT};branch=${SRCBRANCH_mcuboot};name=mcuboot;destsuffix=git/mcuboot \
+            ${SRC_URI_TRUSTED_FIRMWARE_M_QCBOR};branch=${SRCBRANCH_qcbor};name=qcbor;destsuffix=git/qcbor \
+            file://rwx.patch \
             "
 
 # The required dependencies are documented in tf-m/config/config_default.cmake