rainier: Add a virtual ambient temp sensor

Use the virtual-sensor application to put a virtual ambient temperature
sensor on D-Bus.  Currently, it just mirrors the value of the TMP275
ambient temperature sensor, but in the future the output will be based
on all three temp sensors on the panel after the remaining two show up
on D-Bus.

(From meta-ibm rev: f43eab1e5637cf87a38ca2e9a6acc33e5db3a0c3)

Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Change-Id: I187d88c7e1245c7014aee8b9b6c0840daf1e622d
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-ibm/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-ibm/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index 2720e46..7bd2dc2 100644
--- a/meta-ibm/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-ibm/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -24,7 +24,7 @@
 RDEPENDS_${PN}-fan-control_append_ibm-ac-server = " fan-watchdog"
 RDEPENDS_${PN}-fan-control_append_rainier = " fan-watchdog"
 RDEPENDS_${PN}-extras_append_ibm-ac-server = " ${POWER_SERVICE_PACKAGES_AC_SERVER} witherspoon-power-supply-sync phosphor-webui"
-RDEPENDS_${PN}-extras_append_rainier = " ${POWER_SERVICE_PACKAGES_RAINIER} webui-vue dbus-sensors"
+RDEPENDS_${PN}-extras_append_rainier = " ${POWER_SERVICE_PACKAGES_RAINIER} webui-vue dbus-sensors phosphor-virtual-sensor"
 RDEPENDS_${PN}-extras_append_mihawk = " phosphor-webui phosphor-image-signing wistron-ipmi-oem ${POWER_SERVICE_PACKAGES_AC_SERVER}"
 RDEPENDS_${PN}-extras_append_witherspoon-tacoma = " pldm srvcfg-manager webui-vue"