rainier: Add a virtual ambient temp sensor

Use the virtual-sensor application to put a virtual ambient temperature
sensor on D-Bus.  Currently, it just mirrors the value of the TMP275
ambient temperature sensor, but in the future the output will be based
on all three temp sensors on the panel after the remaining two show up
on D-Bus.

(From meta-ibm rev: f43eab1e5637cf87a38ca2e9a6acc33e5db3a0c3)

Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Change-Id: I187d88c7e1245c7014aee8b9b6c0840daf1e622d
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-ibm/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend b/meta-ibm/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend
new file mode 100644
index 0000000..53f8905
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI += "file://virtual_sensor_config.json"
+
+do_install_append_rainier() {
+    install -m 0644 ${WORKDIR}/virtual_sensor_config.json ${D}${datadir}/phosphor-virtual-sensor/
+}