meta-ibm: enable only-allow-boot-when-bmc-ready feature

IBM systems do not want to allow boot operations unless the BMC is in
the Ready state

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: Ic28cb6df9e7f803998a3fb380b3236ed31d6d4ec
diff --git a/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 79eff39..5c5a580 100644
--- a/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -3,6 +3,9 @@
 # IBM systems only want power restore when AC loss occurred
 EXTRA_OEMESON:append = " -Donly-run-apr-on-power-loss=true"
 
+# IBM systems only allow boot operations when BMC is Ready
+EXTRA_OEMESON:append = " -Donly-allow-boot-when-bmc-ready=true"
+
 # The scheduled-host-transition package provides support to
 # schedule power on and off operations for the host at some
 # time in the future. IBM systems will utilize this feature