meta-openembedded: subtree update:713e70bd25..5caca0f7bd

Andreas Müller (1):
      fluidsynth: upgrade 2.1.2 -> 2.1.3

Domarys Correa (6):
      python3-pytest: Update 5.3.5 -> 5.4.2
      python3-pytest-html: Update 1.6 -> 2.1.1
      python3-pytest-metadata: Update 1.8.0 -> 1.9.0
      python3-pytest-asyncio: Update 0.10.0 -> 0.12.0
      python3-pyudev: Update 0.21.0 -> 0.22.0
      python3-pyyaml: Update 5.3 -> 5.3.1

Hongxu Jia (1):
      multipath-tools: fix compiling parallel issue

Kai Kang (1):
      plymouth: disable systemd-integration for sysvinit

Khem Raj (1):
      dfu-util-native: Remove DEPLOY_DIR_TOOLS from sstate-outputdirs

Konrad Weihmann (14):
      pugixml: fix typo for homepage
      distuils-extra: fix typo for DESCRIPTION
      brotli: fix typo for DESCRIPTION
      wxwidgets: fix typo for DESCRIPTION
      passwdqc: remove double modify operation
      zbar: fix typo for DESCRIPTION
      sound-theme-freedesktop: remove double depends
      python3-cmd2: remove double colorama in RDEPENDS
      python3-smbus2: remove duplicate RDEPENDS settings
      python3-twisted: remove double var modification
      spawn-fcgi: fix typo in SUMMARY
      physfs: fix typo for HOMEPAGE
      rest: fix typo for HOMEPAGE
      proftpd: Fix typo for SRC_URI[md5sum]

Leon Anavi (4):
      python3-click: Upgrade 7.0 -> 7.1.2
      python3-dbussy: Upgrade 1.2.1 -> 1.3
      python3-imageio: Upgrade 2.6.0 -> 2.8.0
      python3-colorama: Upgrade 0.4.1 -> 0.4.3

Maciej Pijanowski (1):
      qpdf: fix typo in RDEPENDS

Martin Jansa (1):
      irssi: package libirc_proxy.a in PN-staticdev

Michael Haener (1):
      cockpit: 219 -> 220

Patrick Williams (1):
      net-snmp: refresh patches

Pierre-Jean Texier (2):
      libuv: upgrade 1.36.0 -> 1.38.0
      uftp: upgrade 4.10.2 -> 5.0

Robert P. J. Day (1):
      use weak assignments for PNBLACKLIST in recipe files

Shlomi Vaknin (1):
      add python bitstring package

Zang Ruochen (6):
      libgphoto2: upgrade 2.5.24 -> 2.5.25
      rsyslog: upgrade 8.2002 -> 8.2004
      mosquitto: upgrade 1.6.9 -> 1.6.10
      snort: upgrade 2.9.15 -> 2.9.16
      wireshark: upgrade 3.2.2 -> 3.2.4
      cpuid: upgrade 20200211 -> 20200427

Zheng Ruoqin (5):
      nano: upgrade 4.9.2 -> 4.9.3
      gsoap: upgrade 2.8.100 -> 2.8.103
      logwatch: upgrade 7.5.1 -> 7.5.3
      mcelog: upgrade 168 -> 170
      libnet-dns-perl: upgrade 1.23 -> 1.24

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I697f91df13d9e8d8cb15620aeccd644cdfe53a43
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/snort/snort_2.9.16.bb b/meta-openembedded/meta-networking/recipes-connectivity/snort/snort_2.9.16.bb
new file mode 100644
index 0000000..d8073d8
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-connectivity/snort/snort_2.9.16.bb
@@ -0,0 +1,113 @@
+DESCRIPTION = "snort - a free lightweight network intrusion detection system for UNIX and Windows."
+HOMEPAGE = "http://www.snort.org/"
+SECTION = "net"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=78fa8ef966b48fbf9095e13cc92377c5"
+
+DEPENDS = "xz libpcap libpcre daq libdnet util-linux daq-native libtirpc bison-native"
+
+SRC_URI = "https://www.snort.org/downloads/archive/snort/${BP}.tar.gz \
+    file://snort.init \
+    file://volatiles.99_snort \
+    file://0001-libpcap-search-sysroot-for-headers.patch \
+    file://fix-host-contamination-when-enable-static-daq.patch \
+    file://disable-run-test-program-while-cross-compiling.patch \
+    file://configure.in-disable-tirpc-checking-for-fedora.patch \
+"
+
+SRC_URI[md5sum] = "1cec58babaea3420014d61a93e6e1545"
+SRC_URI[sha256sum] = "9688d8edf1da09dec6574000fb3c0e62f99c56428587616e17c60103c0bcbad7"
+
+UPSTREAM_CHECK_URI = "https://www.snort.org/downloads"
+UPSTREAM_CHECK_REGEX = "snort-(?P<pver>\d+(\.\d+)+)\.tar"
+
+inherit autotools gettext update-rc.d pkgconfig
+
+INITSCRIPT_NAME = "snort"
+INITSCRIPT_PARAMS = "defaults"
+
+EXTRA_OECONF = " \
+    --enable-gre \
+    --enable-linux-smp-stats \
+    --enable-reload \
+    --enable-reload-error-restart \
+    --enable-targetbased \
+    --enable-static-daq \
+    --with-dnet-includes=${STAGING_INCDIR} \
+    --with-dnet-libraries=${STAGING_LIBDIR} \
+    --with-libpcre-includes=${STAGING_INCDIR} \
+    --with-libpcre-libraries=${STAGING_LIBDIR} \
+    --with-daq-includes=${STAGING_INCDIR} \
+    --with-daq-libraries=${STAGING_LIBDIR} \
+"
+
+# if you want to disable it, you need to patch configure.in first
+# AC_CHECK_HEADERS([openssl/sha.h],, SHA_H="no")
+# is called even with --without-openssl-includes
+PACKAGECONFIG ?= "openssl lzma"
+PACKAGECONFIG[openssl] = "--with-openssl-includes=${STAGING_INCDIR} --with-openssl-libraries=${STAGING_LIBDIR}, --without-openssl-includes --without-openssl-libraries, openssl,"
+PACKAGECONFIG[lzma] = "--with-lzma-includes=${STAGING_INCDIR} --with-lzma-libraries=${STAGING_LIBDIR}, --without-lzma-includes --without-lzma-libraries, xz,"
+PACKAGECONFIG[appid] = "--enable-open-appid, --disable-open-appid, luajit, bash"
+
+CFLAGS += "-I${STAGING_INCDIR}/tirpc"
+LDFLAGS += " -ltirpc"
+
+do_install_append() {
+    install -d ${D}${sysconfdir}/snort/rules
+    install -d ${D}${sysconfdir}/snort/preproc_rules
+    install -d ${D}${sysconfdir}/init.d
+    for i in map config conf dtd; do
+        cp ${S}/etc/*.$i ${D}${sysconfdir}/snort/
+    done
+
+    # fix the hardcoded path and lib name
+    # comment out the rules that are not provided
+    sed -i -e 's#/usr/local/lib#${libdir}#' \
+           -e 's#\.\./\(.*rules\)#${sysconfdir}/snort/\1#' \
+           -e 's#\(libsf_engine.so\)#\1.0#' \
+           -e 's/^\(include $RULE_PATH\)/#\1/' \
+           -e 's/^\(dynamicdetection\)/#\1/' \
+           -e '/preprocessor reputation/,/blacklist/ s/^/#/' \
+           ${D}${sysconfdir}/snort/snort.conf
+
+    cp ${S}/preproc_rules/*.rules ${D}${sysconfdir}/snort/preproc_rules/
+    install -m 755 ${WORKDIR}/snort.init ${D}${sysconfdir}/init.d/snort
+
+    install -d ${D}${sysconfdir}/default/volatiles
+    install -m 0644 ${WORKDIR}/volatiles.99_snort ${D}${sysconfdir}/default/volatiles/99_snort
+
+    sed -i -e 's|-fdebug-prefix-map[^ ]*||g; s|-fmacro-prefix-map[^ ]*||g; s|${STAGING_DIR_TARGET}||g' ${D}${libdir}/pkgconfig/*.pc
+}
+
+pkg_postinst_${PN}() {
+    if [ -z "$D" ] && [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
+        ${sysconfdir}/init.d/populate-volatile.sh update
+    fi
+}
+
+FILES_${PN} += " \
+    ${libdir}/snort_dynamicengine/*.so.* \
+    ${libdir}/snort_dynamicpreprocessor/*.so.* \
+    ${libdir}/snort_dynamicrules/*.so.* \
+"
+FILES_${PN}-dbg += " \
+    ${libdir}/snort_dynamicengine/.debug \
+    ${libdir}/snort_dynamicpreprocessor/.debug \
+    ${libdir}/snort_dynamicrules/.debug \
+"
+FILES_${PN}-staticdev += " \
+    ${libdir}/snort_dynamicengine/*.a \
+    ${libdir}/snort_dynamicpreprocessor/*.a \
+    ${libdir}/snort_dynamicrules/*.a \
+    ${libdir}/snort/dynamic_preproc/*.a \
+    ${libdir}/snort/dynamic_output/*.a \
+"
+FILES_${PN}-dev += " \
+    ${libdir}/snort_dynamicengine/*.la \
+    ${libdir}/snort_dynamicpreprocessor/*.la \
+    ${libdir}/snort_dynamicrules/*.la \
+    ${libdir}/snort_dynamicengine/*.so \
+    ${libdir}/snort_dynamicpreprocessor/*.so \
+    ${libdir}/snort_dynamicrules/*.so \
+    ${prefix}/src/snort_dynamicsrc \
+"