pdbg: Bump version to v2.4

This release contains various fixes, and improved support for running
the SBE in istep mode.

Alistair Popple (5):
      libpdbg: Fix segfault when auto-detecting host backend
      libpdbg/host.c: Use reg property index of index to find chip-id
      libpdbg: Fix pib_to_sbefifo
      pdbg: Make getmem always hexdump
      configure.ac: Tag version 2.4

Amitay Isaacs (3):
      main: sbe_istep takes pib target
      istep: Add checking for istep major/minor numbers
      istep: Run all sub-steps if minor is 0

(From meta-openpower rev: b1c73efdc2d7e1ea7b506e1ddb30493aa818bc1d)

Signed-off-by: Joel Stanley <joel@jms.id.au>
Change-Id: Ib621492778359205b2eb497de20567454e1d0534
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openpower/recipes-bsp/pdbg/pdbg_2.4.bb b/meta-openpower/recipes-bsp/pdbg/pdbg_2.4.bb
new file mode 100644
index 0000000..e1651ca
--- /dev/null
+++ b/meta-openpower/recipes-bsp/pdbg/pdbg_2.4.bb
@@ -0,0 +1,15 @@
+SUMMARY     = "PowerPC FSI Debugger"
+DESCRIPTION = "pdbg allows JTAG-like debugging of the host POWER processors"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "2.4+git${SRCPV}"
+
+SRC_URI += "git://github.com/open-power/pdbg.git"
+SRCREV = "8b4611b5d8e7e2279fe4aa80c892fcfe10aa398d"
+
+DEPENDS += "dtc-native"
+
+S = "${WORKDIR}/git"
+
+inherit autotools