meta-phosphor:meson: pkgconfig inherit required

Upstream yocto made a change recently that brought to light a bug in
some of our recipes. If your meson makefiles utilize the dependency()
function then the recipe must also include pkgconfig.

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: Ie85e2a3bd86010c2ce5d08c75fddc1ba348ff891
diff --git a/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb b/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb
index 8844efb..31e8216 100644
--- a/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb
+++ b/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb
@@ -12,7 +12,7 @@
 
 S = "${WORKDIR}/git"
 
-inherit meson
+inherit pkgconfig meson
 inherit systemd
 
 DEPENDS = "boost \