meta-phosphor: switch EXTRA_OEMESON to use override syntax

It was observed that we have different approaches to modifying the
EXTRA_OEMESON variable across our recipes.  The bitbake manual
implies that override syntax (":append") is slightly better and the
poky meson bbclass also prefers it:

    meta/classes/meson.bbclass:EXTRA_OEMESON:append = " ${PACKAGECONFIG_CONFARGS}"

Switch all recipes to use the ":append" override syntax for the
EXTRA_OEMESON variable.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I24e9a27a87c61f374acfb03a63955821fce0dd20
diff --git a/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
index 7ff4b2c..e68960d 100644
--- a/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
+++ b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd_git.bb
@@ -29,9 +29,11 @@
 SYSTEMD_PACKAGES = "${PN}"
 SYSTEMD_SERVICE:${PN} += "${SERVICE_FILE}"
 
-EXTRA_OEMESON += "-Dsnoop-device=${SNOOP_DEVICE}"
-EXTRA_OEMESON += "-Dpost-code-bytes=${POST_CODE_BYTES}"
-EXTRA_OEMESON += "-Dsystemd-target=multi-user.target"
+EXTRA_OEMESON:append = " \
+    -Dsnoop-device=${SNOOP_DEVICE} \
+    -Dpost-code-bytes=${POST_CODE_BYTES} \
+    -Dsystemd-target=multi-user.target \
+"
 
 POSTCODE_SEVENSEG_DEVICE ?= "seven_seg_disp_val"
 SERVICE_FILE_7SEG = " \