meta-phosphor: switch EXTRA_OEMESON to use override syntax

It was observed that we have different approaches to modifying the
EXTRA_OEMESON variable across our recipes.  The bitbake manual
implies that override syntax (":append") is slightly better and the
poky meson bbclass also prefers it:

    meta/classes/meson.bbclass:EXTRA_OEMESON:append = " ${PACKAGECONFIG_CONFARGS}"

Switch all recipes to use the ":append" override syntax for the
EXTRA_OEMESON variable.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I24e9a27a87c61f374acfb03a63955821fce0dd20
diff --git a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
index b834b6b..341c5f7 100644
--- a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager_git.bb
@@ -52,7 +52,7 @@
 # Install the override to set up a Conflicts relation
 SYSTEMD_OVERRIDE_${PN} += "bmc_booted.conf:obmc-led-group-start@bmc_booted.service.d/bmc_booted.conf"
 
-EXTRA_OEMESON += "-Dtests=disabled"
+EXTRA_OEMESON:append = " -Dtests=disabled"
 
 do_compile:prepend() {
     if [ -f "${LED_YAML_PATH}/led.yaml" ]; then