meta-phosphor: switch EXTRA_OEMESON to use override syntax

It was observed that we have different approaches to modifying the
EXTRA_OEMESON variable across our recipes.  The bitbake manual
implies that override syntax (":append") is slightly better and the
poky meson bbclass also prefers it:

    meta/classes/meson.bbclass:EXTRA_OEMESON:append = " ${PACKAGECONFIG_CONFARGS}"

Switch all recipes to use the ":append" override syntax for the
EXTRA_OEMESON variable.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I24e9a27a87c61f374acfb03a63955821fce0dd20
diff --git a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
index d1bdc0f..9a65858 100644
--- a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
+++ b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
@@ -37,4 +37,4 @@
 SYSTEMD_PACKAGES = "${PN}"
 SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.Network.service"
 
-EXTRA_OEMESON += "-Dtests=disabled"
+EXTRA_OEMESON:append = " -Dtests=disabled"