dunfell: move u-boot.inc into aspeed layer

The latest upstream of oe-core has diverged to the point where the
meta-aspeed layer can no longer utilize the shared u-boot.inc

In particular it has introduced a new, buildable config file,
u-boot-initial-env, which is referenced throughout the u-boot.inc file
now.

The best solution is that OpenBMC upstream the changes it requires for
u-boot but resource constraints have prevented that.

The current hybrid approach of using a 2016 version of u-boot, pointing
to source code in openbmc/u-boot but continuing to use the upstream
u-boot.inc really doesn't buy much and causes maintenance issues like
we're seeing here. Best to just pull the working version into
meta-aspeed and just cherry pick in the one change OpenBMC needs which
is the move to python3. The python3 move will be in the next commit in
this series.

The u-boot.inc used here was from poky with this sha:
9052e5b32a0dbc810782be4963e775609b8dcc04

Resolves openbmc/u-boot#24

(From meta-aspeed rev: 8b3d81d7cd9dd0254c3b03dddad18b9e74d2975d)

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I8af2eddfa6690b840af9fc411814fb551cc25230
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
index ac1ead7..8cebe5a 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb
@@ -1,5 +1,5 @@
 require u-boot-common-aspeed_${PV}.inc
-require recipes-bsp/u-boot/u-boot.inc
+require u-boot-aspeed.inc
 
 PROVIDES += "u-boot"
 DEPENDS += "dtc-native"