meta-yadro: Fix version parsing, update AUX rev

AUX Revision info was always taken from the dev_id.json
file if it exists, overriding the value calculated from the
active firmware version string. Also, when AUX info was
calculated, it only properly parsed the dirtyness of the
build.

With this commit the AUX info calculation will properly parse
the git hash part and will include it as higher 3 bytes of
the AUX info. For officially released versions the lower byte
will be zero.

For development versions, bits [7:1] of the fourth byte will
all be 1 as an indicator of non-release branch. For unofficial builds
from release branches those bits will contain a number from
1 to 126 indicating a patch level since the release tag.

In any case the bit 0 of byte 4 is a dirtyness indicator.
If the sources used to build the firmware were modified compared
to the git hash, this bit will be 1.

WARNING: For the AUX decoding from version string to work
         properly, the dev_id.json file must NOT contain
         the `aux` property.

(From meta-yadro rev: 468784ebfd8009e34207018c44858e2b6bc28762)

End-user-impact: Version info is properly represented in the
                 AUX Revision Info fields in response to the
                 IPMI Get Device ID command (ipmitool mc info)
Signed-off-by: Alexander Amelkin <a.amelkin@yadro.com>
Change-Id: Iec376659ab108283e224618e3f6afed24a86b199
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-yadro/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-yadro/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index a326584..b4b1a2f 100644
--- a/meta-yadro/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-yadro/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -1,6 +1,7 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
-SRC_URI_append  = "\
+SRC_URI += "\
     file://0001-Add-support-for-persistent-only-settings.patch \
     file://0002-Add-support-for-boot-initiator-mailbox.patch \
+    file://0003-Fix-version-parsing-update-AUX-revision-info.patch \
 "