phosphor-networkd: Use meson instead of autotools

Change-Id: I7f4860405420eead896343a5dfee769b3781ba76
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
index 0f235ac..94090fb 100644
--- a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
+++ b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
@@ -6,7 +6,7 @@
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
 
-inherit autotools pkgconfig
+inherit meson pkgconfig
 inherit python3native
 inherit systemd
 
@@ -14,7 +14,6 @@
 SRCREV = "1e710d04a61092b45ff4ccd58656cb5cee3cba5b"
 
 DEPENDS += "systemd"
-DEPENDS += "autoconf-archive-native"
 DEPENDS += "sdbusplus ${PYTHON_PN}-sdbus++-native"
 DEPENDS += "sdeventplus"
 DEPENDS += "phosphor-dbus-interfaces"
@@ -25,18 +24,15 @@
 PACKAGECONFIG ??= "uboot-env default-link-local-autoconf default-ipv6-accept-ra"
 
 UBOOT_ENV_RDEPENDS = "${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'}"
-PACKAGECONFIG[uboot-env] = "--with-uboot-env,--without-uboot-env,,${UBOOT_ENV_RDEPENDS}"
-PACKAGECONFIG[default-link-local-autoconf] = "--enable-link-local-autoconfiguration,--disable-link-local-autoconfiguration,,"
-PACKAGECONFIG[default-ipv6-accept-ra] = "--enable-ipv6-accept-ra,--disable-ipv6-accept-ra,,"
-PACKAGECONFIG[nic-ethtool] = "--enable-nic-ethtool,--disable-nic-ethtool,,"
-PACKAGECONFIG[sync-mac] = "--enable-sync-mac,--disable-sync-mac,nlohmann-json,"
+PACKAGECONFIG[uboot-env] = "-Duboot-env=true,-Duboot-env=false,,${UBOOT_ENV_RDEPENDS}"
+PACKAGECONFIG[default-link-local-autoconf] = "-Ddefault-link-local-autoconf=true,-Ddefault-link-local-autoconf=false,,"
+PACKAGECONFIG[default-ipv6-accept-ra] = "-Ddefault-ipv6-accept-ra=true,-Ddefault-ipv6-accept-ra=false,,"
+PACKAGECONFIG[nic-ethtool] = "-Dnic-ethtool=true,-Dnic-ethtool=false,,"
+PACKAGECONFIG[sync-mac] = "-Dsync-mac=true,-Dsync-mac=false,nlohmann-json,"
 
 S = "${WORKDIR}/git"
 
-SERVICE_FILE = "xyz.openbmc_project.Network.service"
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}"
+FILES_${PN} += "${datadir}/dbus-1/system.d"
 
-EXTRA_OECONF = " \
-  SYSTEMD_TARGET="multi-user.target" \
-"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Network.service"