blob: dbad8c87288a6d5b3f02c05a6e95adf7a522e02a [file] [log] [blame]
SECTION = "console/network"
SUMMARY = "dhcpcd - a DHCP client"
DESCRIPTION = "dhcpcd runs on your machine and silently configures your \
computer to work on the attached networks without trouble \
and mostly without configuration."
HOMEPAGE = "http://roy.marples.name/projects/dhcpcd/"
LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=9674cc803c5d71306941e6e8b5c002f2"
UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/"
SRC_URI = "https://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \
file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \
file://0002-src-privsep-linux.c-add-support-for-arc-28.patch \
file://dhcpcd.service \
file://dhcpcd@.service \
"
SRC_URI[sha256sum] = "41a69297f380bf15ee8f94f73154f8c2bca7157a087c0d5aca8de000ba1d4513"
inherit pkgconfig autotools-brokensep systemd useradd
SYSTEMD_SERVICE:${PN} = "dhcpcd.service"
PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev"
PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
# ntp conflicts with chrony
PACKAGECONFIG[ntp] = "--with-hook=ntp, , ,ntp"
PACKAGECONFIG[chrony] = "--with-hook=ntp, , ,chrony"
PACKAGECONFIG[ypbind] = "--with-eghook=yp, , ,ypbind-mt"
EXTRA_OECONF = "--enable-ipv4 \
--dbdir=${localstatedir}/lib/${BPN} \
--sbindir=${base_sbindir} \
--runstatedir=/run \
--enable-privsep \
--privsepuser=dhcpcd \
--with-hooks \
--with-eghooks \
"
USERADD_PACKAGES = "${PN}"
USERADD_PARAM:${PN} = "--system -d ${localstatedir}/lib/${BPN} -M -s /bin/false -U dhcpcd"
do_install:append () {
# install systemd unit files
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/dhcpcd*.service ${D}${systemd_system_unitdir}
chmod 700 ${D}${localstatedir}/lib/${BPN}
chown dhcpcd:dhcpcd ${D}${localstatedir}/lib/${BPN}
}
FILES:${PN}-dbg += "${libdir}/dhcpcd/dev/.debug"