blob: 1ea6bb56e6d47b3defae79d0166101789aba3ca0 [file] [log] [blame]
SUMMARY = "A library for property-based testing"
HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
LICENSE = "MPL-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
PYPI_PACKAGE = "hypothesis"
inherit pypi setuptools3 ptest
SRC_URI += " \
file://run-ptest \
file://test_binary_search.py \
file://test_rle.py \
"
SRC_URI[sha256sum] = "10699f595eebb9410fd902908aa13aece19be5c437b405092be34f60f69f7999"
RDEPENDS:${PN} += " \
python3-attrs \
python3-compression \
python3-core \
python3-json \
python3-sortedcontainers \
python3-statistics \
python3-unittest \
"
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/examples
install -m 0755 ${WORKDIR}/test_binary_search.py ${D}${PTEST_PATH}/examples/
install -m 0755 ${WORKDIR}/test_rle.py ${D}${PTEST_PATH}/examples/
}
BBCLASSEXTEND = "native nativesdk"