blob: acb4b4ac20c918d1a7fab223bd5dbefeff88ca69 [file] [log] [blame]
SUMMARY = "The module provides handy URL class for url parsing and changing"
HOMEPAGE = "https://github.com/aio-libs/yarl/"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e581798a7b985311f29fa3e163ea27ae"
SRC_URI[sha256sum] = "8e7ebaf62e19c2feb097ffb7c94deb0f0c9fab52590784c8cd679d30ab009162"
SRC_URI += "file://run-ptest"
PYPI_PACKAGE = "yarl"
inherit pypi ptest setuptools3
RDEPENDS:${PN} = "\
${PYTHON_PN}-multidict \
${PYTHON_PN}-idna \
"
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}