blob: 0d8fdf63733099b6bc0a2797a7714cd445f59dac [file] [log] [blame]
SUMMARY = "Simple powerful testing with python"
HOMEPAGE = "https://pypi.org/project/pytest/"
DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries."
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b"
SRC_URI[sha256sum] = "131b36680866a76e6781d13f101efb86cf674ebb9762eb70d3082b6f29889e89"
DEPENDS = "python3-setuptools-scm-native"
inherit update-alternatives pypi setuptools3
RDEPENDS:${PN}:class-target += " \
${PYTHON_PN}-atomicwrites \
${PYTHON_PN}-attrs \
${PYTHON_PN}-debugger \
${PYTHON_PN}-doctest \
${PYTHON_PN}-importlib-metadata \
${PYTHON_PN}-iniconfig \
${PYTHON_PN}-json \
${PYTHON_PN}-more-itertools \
${PYTHON_PN}-packaging \
${PYTHON_PN}-pathlib2 \
${PYTHON_PN}-pluggy \
${PYTHON_PN}-py \
${PYTHON_PN}-setuptools \
${PYTHON_PN}-six \
${PYTHON_PN}-toml \
${PYTHON_PN}-wcwidth \
"
ALTERNATIVE:${PN} += "py.test pytest"
NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
BBCLASSEXTEND = "native nativesdk"