linux: Move to 4.18 based tree

This rebases the OpenBMC kernel tree on a 4.18 base. There are 85
patches backported from 4.19-rc1, and the following 39 out of tree
patches:

Alexander Amelkin (1):
      mtd: spi-nor: fix options for mx66l51235f

Andrew Jeffery (8):
      ARM: dts: aspeed: witherspoon: Update max31785 node
      dt-bindings: hwmon: pmbus: Add Maxim MAX31785 documentation
      pmbus (max31785): Add support for devicetree configuration
      pmbus (core): One-shot retries for failure to set page
      pmbus (core): Use driver callbacks in pmbus_get_fan_rate()
      pmbus (max31785): Wrap all I2C accessors in one-shot failure handlers
      soc: aspeed: Miscellaneous control interfaces
      ARM: dts: aspeed-g5: Expose VGA and SuperIO scratch registers

Benjamin Herrenschmidt (4):
      ARM: dts: aspeed: Romulus system can use coprocessor for FSI
      ARM: dts: aspeed: Palmetto system can use coprocessor for FSI
      ARM: dts: aspeed: Add Power8 CFAM description for use by Palmetto
      ARM: dts: aspeed: Add Power9 CFAM description

Brad Bishop (1):
      ARM: configs: Remove atags from Aspeed G4 config

Christopher Bostic (1):
      iio: dps310: Temperature measurement errata

Cyril Bur (1):
      misc: Add ASPEED mbox driver

Cédric Le Goater (6):
      mtd: spi-nor: aspeed: use command mode for reads
      mtd: spi-nor: aspeed: add support for SPI dual IO read mode
      mtd: spi-nor: aspeed: link controller with the ahb clock
      mtd: spi-nor: aspeed: optimize read mode
      mtd: spi-nor: aspeed: limit the maximum SPI frequency
      ARM: dts: aspeed: Add "spi-max-frequency" property

Edward A. James (2):
      drivers/fsi: Add On-Chip Controller (OCC) driver
      hwmon: Add On-Chip Controller (OCC) hwmon driver

Joel Stanley (15):
      ARM: dts: aspeed-palmetto: Add LPC control node
      ARM: dts: aspeed-palmetto: Add i2c OCC hwmon node
      ARM: dts: aspeed-ast2500: Update flash layout
      ARM: dts: aspeed: Add LPC mailbox node
      ARM: dts: aspeed: Enable mbox
      iio: Add driver for Infineon DPS310
      ARM: dts: aspeed-g4: Expose SuperIO scratch registers
      ARM: dts: aspeed-g5: Add resets and clocks to GFX node
      ARM: dts: aspeed: Enable the GFX IP
      ARM: dts: aspeed: Enable VHUB on Romulus
      drm: Add ASPEED GFX driver
      drm: aspeed: Debugfs interface for GFX registers
      dt-bindings: gpu: Add ASPEED GFX bindings document
      ARM: config: aspeed: Add out of tree drivers
      ARM: dts: Add OCC description to Power9 dtsi

(From meta-aspeed rev: 2f1187b1bff8d52ddd93f2c5b598eec7ddc9f4f6)

Change-Id: I4035abcdcfa9a083599e27661fed5351fc6532fd
Signed-off-by: Joel Stanley <joel@jms.id.au>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
index d719ac7..46884a3 100644
--- a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
+++ b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
@@ -1,6 +1,6 @@
-KBRANCH ?= "dev-4.17"
-LINUX_VERSION ?= "4.17.18"
+KBRANCH ?= "dev-4.18"
+LINUX_VERSION ?= "4.18.5"
 
-SRCREV="80d901318acc389e6e09698a8927bf6eb29da314"
+SRCREV="b9bdffdd891707c4d6995fbc7118fdb9ea426c47"
 
 require linux-aspeed.inc