Switch bmcweb to meson build system & bump

- Meson already seems to pass -pipe as a part of default project
  options,as it was redundant removing it.
- This commit would switch and leverage the the meson build
  system while building bmcweb.
- This commit overrides the build type to minsize as it is an yocto build

(From meta-phosphor rev: f1517990b64cd99f4f4ec9f18241d8e089ffccab)

Signed-off-by: Manojkiran Eda <manojkiran.eda@gmail.com>
Change-Id: I6ea02820471c54e46863263355f6651b8477ca45
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
index 566d1a3..efc13c1 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -13,7 +13,7 @@
 SRC_URI = "git://github.com/openbmc/bmcweb.git"
 
 PV = "1.0+git${SRCPV}"
-SRCREV = "d609fd6ebd1af3a9cbba0dd646aee27da8e1f971"
+SRCREV = "cc0904473c19977eb0b9789b3c1be54a74ca873d"
 
 S = "${WORKDIR}/git"
 
@@ -31,10 +31,10 @@
 
 FILES_${PN} += "${datadir}/** "
 
-inherit cmake
+inherit meson
 
-EXTRA_OECMAKE = "-DBMCWEB_BUILD_UT=OFF -DYOCTO_DEPENDENCIES=ON"
+EXTRA_OEMESON = "--buildtype=minsize -Dtests=disabled -Dyocto-deps=enabled"
 
 SYSTEMD_SERVICE_${PN} += "bmcweb.service bmcweb.socket"
 
-FULL_OPTIMIZATION = "-Os -pipe "
+FULL_OPTIMIZATION = "-Os "