Add phosphor-gevent recipe

And make it the default for Phosphor.

Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Change-Id: I531aa457bcc0fae4d4fff833fb1815a12af53edc
diff --git a/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent.bb b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent.bb
new file mode 100644
index 0000000..91fea10
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Phosphor Rocket startup script"
+DESCRIPTION = "Phosphor Rocket startup script."
+HOMEPAGE = "http://github.com/openbmc/phosphor-rest-server"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+inherit allarch
+inherit setuptools
+inherit obmc-phosphor-systemd
+
+PROVIDES += "virtual/obmc-wsgihost"
+RPROVIDES_${PN} += "virtual-obmc-wsgihost"
+
+RDEPENDS_${PN} += " \
+        python-gevent \
+        "
+SRC_URI += "git://github.com/openbmc/phosphor-rest-server"
+
+SRCREV = "7bc6d8d39daebe3529c4c31a8caa0288dfb0ecd5"
+
+S = "${WORKDIR}/git/servers/gevent"
+
+SYSTEMD_SERVICE_${PN} += "${PN}.service ${PN}.socket"