Move dbus-sensors to meson

This commit is designed to go in tandem with:
https://gerrit.openbmc-project.xyz/c/openbmc/dbus-sensors/+/27100

Which removes the cmake support entirely, and moves 100% to meson.  This
provides consistency for openbmc in its project generation.

This was previously checked in and +1ed on meta-phosphor.  This commit
simply moves the content to openbmc/openbmc
https://gerrit.openbmc-project.xyz/c/openbmc/meta-phosphor/+/37365

Tested:
Checked out 27100 and built.

Signed-off-by: Ed Tanous <ed@tanous.net>
Change-Id: I96d46b110df0787692df9fecab6e537be19a74ae
diff --git a/meta-phosphor/recipes-phosphor/sensors/dbus-sensors_git.bb b/meta-phosphor/recipes-phosphor/sensors/dbus-sensors_git.bb
index 035b4c6..aaae804 100644
--- a/meta-phosphor/recipes-phosphor/sensors/dbus-sensors_git.bb
+++ b/meta-phosphor/recipes-phosphor/sensors/dbus-sensors_git.bb
@@ -2,7 +2,7 @@
 DESCRIPTION = "Dbus Sensor Services Configured from D-Bus"
 
 SRC_URI = "git://github.com/openbmc/dbus-sensors.git"
-SRCREV = "2a40e939307c5ffccf19b19d500eac5935c63009"
+SRCREV = "feb19ef095c4ab9ec037b2f23ab6318f59a96eab"
 
 PV = "0.1+git${SRCPV}"
 
@@ -19,18 +19,20 @@
     ipmbsensor \
     mcutempsensor \
     psusensor \
+    external \
     "
 
-PACKAGECONFIG[adcsensor] = "-DDISABLE_ADC=OFF, -DDISABLE_ADC=ON"
-PACKAGECONFIG[cpusensor] = "-DDISABLE_CPU=OFF, -DDISABLE_CPU=ON"
-PACKAGECONFIG[exitairtempsensor] = "-DDISABLE_EXIT_AIR=OFF, -DDISABLE_EXIT_AIR=ON"
-PACKAGECONFIG[externalsensor] = "-DDISABLE_EXTERNAL=OFF, -DDISABLE_EXTERNAL=ON"
-PACKAGECONFIG[fansensor] = "-DDISABLE_FAN=OFF, -DDISABLE_FAN=ON"
-PACKAGECONFIG[hwmontempsensor] = "-DDISABLE_HWMON_TEMP=OFF, -DDISABLE_HWMON_TEMP=ON"
-PACKAGECONFIG[intrusionsensor] = "-DDISABLE_INTRUSION=OFF, -DDISABLE_INTRUSION=ON"
-PACKAGECONFIG[ipmbsensor] = "-DDISABLE_IPMB=OFF, -DDISABLE_IPMB=ON"
-PACKAGECONFIG[mcutempsensor] = "-DDISABLE_MCUTEMP=OFF, -DDISABLE_MCUTEMP=ON"
-PACKAGECONFIG[psusensor] = "-DDISABLE_PSU=OFF, -DDISABLE_PSU=ON"
+PACKAGECONFIG[adcsensor] = "-Dadc=enabled, -Dadc=disabled"
+PACKAGECONFIG[cpusensor] = "-Dcpu=enabled, -Dcpu=disabled"
+PACKAGECONFIG[exitairtempsensor] = "-Dexit-air=enabled, -Dexit-air=disabled"
+PACKAGECONFIG[fansensor] = "-Dfan=enabled, -Dfan=disabled"
+PACKAGECONFIG[hwmontempsensor] = "-Dhwmon-temp=enabled, -Dhwmon-temp=disabled"
+PACKAGECONFIG[intrusionsensor] = "-Dintrusion=enabled, -Dintrusion=disabled"
+PACKAGECONFIG[ipmbsensor] = "-Dipmb=enabled, -Dipmb=disabled"
+PACKAGECONFIG[mcutempsensor] = "-Dmcu=enabled, -Dmcu=disabled"
+PACKAGECONFIG[psusensor] = "-Dpsu-temp=enabled, -Dpsu-temp=disabled"
+PACKAGECONFIG[nvmesensor] = "-Dnvme=enabled, -Dnvme=disabled"
+PACKAGECONFIG[external] = "-Dexternal=enabled, -Dexternal=disabled"
 
 SYSTEMD_SERVICE_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'adcsensor', \
                                                'xyz.openbmc_project.adcsensor.service', \
@@ -64,8 +66,7 @@
                                                '', d)}"
 
 DEPENDS = "boost nlohmann-json sdbusplus i2c-tools libgpiod"
-inherit cmake systemd
+inherit meson systemd
 
 S = "${WORKDIR}/git"
 
-EXTRA_OECMAKE = "-DYOCTO=1"