subtree updates

meta-raspberrypi: 40283f583b..ca11a291ee:
  Martin Schuessler (1):
        omxplayer: remove hardcoded tune and arch from Makefile

poky: 111b7173fe..50d272863d:
  Adrian Bunk (3):
        wireless-regdb: Add recipe
        go: Upgrade 1.12.5 -> 1.12.6
        libxslt: Fix CVE-2019-11068

  Alexander Kanavin (7):
        vala: upgrade 0.44.3 -> 0.44.5
        libnewt: merge libnewt-python recipe into the main recipe
        epiphany: update to 3.32.3
        btrfs-tools: update to 5.1.1
        createrepo-c: upgrade 0.14.0 -> 0.14.2
        librepo: upgrade 1.10.2 -> 1.10.3
        libmodulemd: upgrade 2.4.0 -> 2.5.0

  Alistair Francis (6):
        libffi: Add RISC-V support
        opensbi: Initial commit of OpenSBI
        qemuriscv64: Add the QEMU RISC-V 64-bit machine
        linux-yocto: Mark qemuriscv64 as compatible
        qemuriscv: Build uImage for RISC-V machines
        qemuriscv64: Fix QB_OPT_APPEND overwrite

  Anuj Mittal (1):
        runtime/cases/logrotate: make test more reliable

  Ayoub Zaki (1):
        kernel-fitimage: introduce FIT_HASH_ALG

  Changqing Li (1):
        gcc-runtime: fix C++ header mapping for n32/x32 tune

  Chee Yang Lee (1):
        wic/bootimg-efi: allow multiple initrd

  Chen Qi (2):
        manifest.py: fix test_SDK_manifest_entries
        target-sdk-provides-dummy: add libperl.so.5 to DUMMY_PROVIDES

  Chris PeBenito (1):
        volatile-binds: Change cp to use -a instead of -p.

  Denys Dmytriyenko (2):
        mtd-utils: upgrade 2.0.2 -> 2.1.0+
        mtd-utils: add "jffs" and "ubifs" PACKAGECONFIG options

  He Zhe (1):
        kernel: qemuarmv5: Update machine overrides of KERNEL_DEVICETREE

  Joe Slater (1):
        parted: change device manager check in ptest

  Joshua Watt (1):
        python3: Disable PGO for reproducible builds

  Kai Kang (3):
        systemd-conf: not configure network for nfs root
        rng-tools: 6.6 -> 6.7
        qemu: disable capstone for 32-bit mips with multilib

  Lei Maohui (1):
        openssl: Fix a build bug on aarch64BE.

  Martin Jansa (4):
        buildhistory: show time spent writting buildhistory
        base.bbclass: define PACKAGECONFIG_CONFARGS before only sometimes appending to it
        serf: stop scons trying to create directories in hosts rootfs
        bitbake: tests/utils.py: add one more test cases for bb.utils.vercmp_string

  Matt Madison (1):
        apt: fix permissions on apt-daily script for systemd

  Mingli Yu (1):
        bitbake: add iconv to HOSTTOOLS

  Pierre Le Magourou (4):
        cve-update-db: New recipe to update CVE database
        cve-check: Remove dependency to cve-check-tool-native
        cve-check: Manage CVE_PRODUCT with more than one name
        cve-check: Consider CVE that affects versions with less than operator

  Ricardo Ribalda Delgado (4):
        dpkg: Use less as pager
        meson: Fix native patch to python3
        rootfs: Fix dependency for every dpkg run
        python3: python3: Fix build error x86->x86

  Richard Purdie (7):
        libxcrypt: Switch to disable obsolete APIs
        libxcrypt-compat: Add recipe to build the obsolete APIs
        uninative-tarball: Add libxcrypt-compat
        openssh: Add missing DEPENDS on virtual/crypt
        lttng-tools: Filter ptest output to remove random tmp directories
        cmake: Clarify comment in cmake toolchain file
        uninative: Update to 2.6 release

  Robert Yang (2):
        linux-dummy: Add do_compile_kernelmodules
        make-mod-scripts: Depends on bison-native

  Ross Burton (7):
        insane: improve buildpath warning messages
        insane: remove empty test that does nothing
        binconfig: don't try to fix up .la files
        libsdl2: use binconfig-disabled
        glib-2.0: fix host path appearing in gsocketclient-slow test script
        oeqa/logparser: ignore test failure commentary
        python: make 'python' install everything instead of just the interpretter

  Stefano Babic (1):
        systat: systemd never enables the service

  Tim Orling (4):
        perl-rdepends.txt: more ptest dependencies fixes
        libxml-sax-perl: upgrade 1.00 -> 1.02
        libmodule-build-perl: move from meta-perl
        libmodule-build-perl: upgrade 0.4224 -> 0.4229; enable ptest

  Yi Zhao (2):
        shadow: fix configure error with dash
        less: upgrade 550 -> 551

  Zang Ruochen (9):
        lighttpd: Upgrade 1.4.53 -> 1.4.54
        libevent:upgrade 2.1.8 -> 2.1.10
        libevdev:upgrade 1.6.0 -> 1.7.0
        gnutls:upgrade 3.6.7 -> 3.6.8
        gnupg:upgrade 2.2.15 -> 2.2.16
        curl:upgrade 7.64.1 -> 7.65.1
        lttng-ust:upgrade 2.10.3 -> 2.10.4
        xkeyboard:upgrade 2.26 -> 2.27
        gobject-introspection:upgrade 1.60.1 -> 1.60.2

Change-Id: I3df401c6822e1c5c2ee9cff57c7264fe31c6d22d
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/poky/meta/recipes-devtools/qemu/qemu_4.0.0.bb b/poky/meta/recipes-devtools/qemu/qemu_4.0.0.bb
index f119215..7677609 100644
--- a/poky/meta/recipes-devtools/qemu/qemu_4.0.0.bb
+++ b/poky/meta/recipes-devtools/qemu/qemu_4.0.0.bb
@@ -7,6 +7,7 @@
 RDEPENDS_${PN}_class-target += "bash"
 
 EXTRA_OECONF_append_class-target = " --target-list=${@get_qemu_target_list(d)}"
+EXTRA_OECONF_append_class-target_mipsarcho32 = "${@bb.utils.contains('BBEXTENDCURR', 'multilib', ' --disable-capstone', '', d)}"
 EXTRA_OECONF_append_class-nativesdk = " --target-list=${@get_qemu_target_list(d)}"
 
 do_install_append_class-nativesdk() {