Add virtual/openpower-fru-properties

This virtual provides an output file in YAML format, which has
property:value pairs for FRUs of interest.

Add a native recipe that extracts property values from the MRW. Set this
as the default for OpenPOWER systems.

Change-Id: Ib56d253aaceeb84bdb40381147915b3cfc80942a
Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example-native.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example-native.bb
new file mode 100644
index 0000000..aa79432
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example-native.bb
@@ -0,0 +1,22 @@
+SUMMARY = "FRU properties config for openpower-vpd-parser"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit openpower-fru-vpd
+
+SRC_URI += "file://example.yaml"
+
+PROVIDES += "virtual/openpower-fru-properties"
+
+S = "${WORKDIR}"
+
+do_install() {
+        # This recipe is supposed to create an output yaml file with
+        # FRU property values extracted from the MRW. This example recipe
+        # provides a sample output file.
+
+        DEST=${D}${properties_datadir}
+        install -d ${DEST}
+        install example.yaml ${DEST}
+}