Add virtual/openpower-fru-properties

This virtual provides an output file in YAML format, which has
property:value pairs for FRUs of interest.

Add a native recipe that extracts property values from the MRW. Set this
as the default for OpenPOWER systems.

Change-Id: Ib56d253aaceeb84bdb40381147915b3cfc80942a
Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd.bb
index 1efe2ea..4d7114a 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd.bb
@@ -14,6 +14,7 @@
 DEPENDS += " \
         virtual/openpower-fru-vpd-layout \
         virtual/openpower-fru-inventory \
+        virtual/openpower-fru-properties \
         sdbusplus \
         phosphor-logging \
         python-mako-native \
@@ -30,7 +31,10 @@
 
 S = "${WORKDIR}/git"
 
-EXTRA_OECONF = "FRU_YAML=${STAGING_DIR_NATIVE}${vpdlayout_datadir}/layout.yaml"
+EXTRA_OECONF = " \
+             FRU_YAML=${STAGING_DIR_NATIVE}${vpdlayout_datadir}/layout.yaml \
+             PROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/out.yaml \
+             "
 
 do_install_append() {
         SRC=${STAGING_DATADIR_NATIVE}${inventory_datadir_name}