meta-ampere: Cleanup for Yocto override syntax change

Run convert-overrides.py meta-ampere and update missing changes as
below:
- Change all _mtjade to :mtjade
- Change all _${PN} to :${PN}

Tested:
1. Check compilation without problem.
2. Check basic functions like switch UART mux, power control.

Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com>
Change-Id: I42038b2a98ed1951d6c770bdf49f5fc440f8163e
diff --git a/meta-ampere/meta-jade/recipes-phosphor/gpio/host-gpio-handling.bb b/meta-ampere/meta-jade/recipes-phosphor/gpio/host-gpio-handling.bb
index 4358b12..79bfb72 100644
--- a/meta-ampere/meta-jade/recipes-phosphor/gpio/host-gpio-handling.bb
+++ b/meta-ampere/meta-jade/recipes-phosphor/gpio/host-gpio-handling.bb
@@ -6,11 +6,11 @@
 inherit obmc-phosphor-systemd
 
 DEPENDS += "virtual/obmc-gpio-monitor"
-RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
+RDEPENDS:${PN} += "virtual/obmc-gpio-monitor"
 
 OBMC_HOST_ACK_MONITOR_INSTANCES = "reboot_ack shutdown_ack"
 
-SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/reboot_ack \
+SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/gpio/reboot_ack \
                                   obmc/gpio/shutdown_ack \
                                  "
 
@@ -19,5 +19,5 @@
 TGT = "multi-user.target"
 FMT = "../${TMPL}:${TGT}.requires/${INSTFMT}"
 
-SYSTEMD_SERVICE_${PN} += "ampere-host-shutdown-ack@.service"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_ACK_MONITOR_INSTANCES')}"
+SYSTEMD_SERVICE:${PN} += "ampere-host-shutdown-ack@.service"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_ACK_MONITOR_INSTANCES')}"