Remove the extra space from the directory name

There was extra space at the start of the path
and due to that bitbake creates the directory
named "".
This fix strips the spaces from either end.

Resolves openbmc/openbmc#1413

Change-Id: I860aa9cbf95c556b938c591e2438b0504207a9f9
Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
diff --git a/meta-phosphor/classes/obmc-phosphor-discovery-service.bbclass b/meta-phosphor/classes/obmc-phosphor-discovery-service.bbclass
index 9b66e7e..73a4875 100644
--- a/meta-phosphor/classes/obmc-phosphor-discovery-service.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-discovery-service.bbclass
@@ -55,8 +55,8 @@
     if not avahi_enabled and slp_enabled:
         return
 
-    avahi_service_dir = d.getVar('AVAHI_SERVICES_DIR', True)
-    slp_service_dir = d.getVar('SLP_SERVICES_DIR', True)
+    avahi_service_dir = d.getVar('AVAHI_SERVICES_DIR', True).strip()
+    slp_service_dir = d.getVar('SLP_SERVICES_DIR', True).strip()
 
     if not os.path.exists(avahi_service_dir):
         os.makedirs(avahi_service_dir)