Add mihawk sensor, fan control and d-bus monitor

Most of mihawk's sensors are different from witherspoon, so I temporarily
added the mihawk part and did not change the witherspoon.

Add mihawk version of fan control and d-bus monitor.
Mihawk does not have a water cooled mode, so another independent folder is added.

Tested: 1.Shut down the system if more than three cores
          have a temperature greater than 100 degrees Celcius.
        2.Fan control support cpu core, dimm, Onboard.
        3.Confirm that sensor is able to return normally via REST.

(From meta-ibm rev: 949f91431bba2f0139cc823d674a741f9590c885)

Signed-off-by: Ben Pai <Ben_Pai@wistron.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Change-Id: Icc401f32c67b622f0f1448e1166112e02c135a8f
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/thermal-policy.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/thermal-policy.bb
index 9fb7d25..5631ec4 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/thermal-policy.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/dbus/thermal-policy.bb
@@ -8,7 +8,7 @@
 
 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
 
-SRC_URI += "file://thermal-policy.yaml"
+SRC_URI = "file://thermal-policy.yaml"
 
 do_install() {
         install -D ${WORKDIR}/thermal-policy.yaml ${D}${config_dir}/thermal-policy.yaml