nicole: u-boot: Add system reset state support

This is a backport of the patch file from intel-bmc/openbmc repository.
It makes the u-boot to add the system reset status to the bootargs.

tested: the /proc/cmdline must contain:
 - resetreason=power after cold bmc boot
 - resetreason=watchdog after warm bmc reboot

(From meta-yadro rev: 3851142232368d6db77b674e79541d677d68aa41)

Change-Id: Ic46b3e497e1c8df4e5bd6d2cf2706e1daba80965
Signed-off-by: Alexander Filippov <a.filippov@yadro.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-yadro/meta-nicole/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend b/meta-yadro/meta-nicole/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
new file mode 100644
index 0000000..f0ff09e
--- /dev/null
+++ b/meta-yadro/meta-nicole/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_append := "${THISDIR}/files:"
+
+SRC_URI_append = " \
+    file://0001-Add-system-reset-status-support.patch \
+    "