Add machine readable workbook recipe.

Add a recipe that will pull down the MRW XML file <machine>.xml
and install it into the fakeroot in /usr/share/obmc-mrw so it's
available for other components to process.  It gets the SRC_URI
from PHOSPHOR_MRW_URI, which would be set by the <machine>.conf
file ideally.

Change-Id: I351a9a0a88f709085df53da96bccb3d8db145de4
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb b/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb
new file mode 100644
index 0000000..3ce4c97
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Phosphor OpenBMC machine readable workbook"
+DESCRIPTION = "Pulls down system specific data"
+PR = "r1"
+
+S = "${WORKDIR}/git"
+
+inherit obmc-phosphor-license
+inherit native
+
+PHOSPHOR_MRW_URI ?= "http://missing-mrw-uri"
+SRC_URI += "${PHOSPHOR_MRW_URI}"
+SRCREV = "${PHOSPHOR_MRW_REV}"
+
+do_install() {
+    install -d ${datadir}/obmc-mrw
+    install -m 0644 ${MACHINE}.xml ${datadir}/obmc-mrw
+}
+