sdeventplus: Use meson instead of autotools
This will allow us to get rid of autotools in the upstream sources.
(From meta-phosphor rev: fe1b9e8f48bece7e78be566de44d634a6c5a4b35)
Change-Id: I1f1703d742d227604c95f6d86ce5d8b44a3240bd
Signed-off-by: William A. Kennington III <wak@google.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb b/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb
index 54187c9..d1ddff9 100644
--- a/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb
+++ b/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb
@@ -6,17 +6,16 @@
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-inherit autotools pkgconfig
+inherit meson pkgconfig
DEPENDS += " \
- autoconf-archive-native \
stdplus \
systemd \
"
-EXTRA_OECONF_append += " \
- --disable-examples \
- --disable-tests \
+EXTRA_OEMESON = " \
+ -Dexamples=false \
+ -Dtests=disabled \
"
SRC_URI += "git://github.com/openbmc/sdeventplus"