blob: 3b707378cb188963c21ec87b9f8b6b8c7f2a6199 [file] [log] [blame]
Brad Bishope36358c2016-06-08 22:03:59 -04001# Common code for systemd based services.
2#
3# Prior to inheriting this class, recipes can define services like this:
4#
5# SYSTEMD_SERVICE_${PN} = "foo.service bar.socket baz@.service"
6#
7# and these files will be added to the main package if they exist.
8#
9# Alternatively this class can just be inherited and
Brad Bishop62d676a2016-07-11 00:42:58 -040010# ${PN}.service will be added to the main package.
Brad Bishop687146f2016-07-11 13:05:26 -040011#
12# Other variables:
13# INHIBIT_SYSTEMD_RESTART_POLICY_${unit}
14# Inhibit the warning that is displayed if a service unit without a
15# restart policy is detected.
Brad Bishop51528fe2016-07-14 19:34:06 -040016#
Brad Bishop5e329ba2016-08-17 12:08:16 -040017# SYSTEMD_SUBSTITUTIONS_${path-relative-to-system_unitdir}
18# Variables in this list will be substituted in the specified
Brad Bishop51528fe2016-07-14 19:34:06 -040019# file during install (if bitbake finds python {format} strings
Brad Bishop5e329ba2016-08-17 12:08:16 -040020# in the file itself). List entries take the form:
Brad Bishop51528fe2016-07-14 19:34:06 -040021# VAR:VALUE
22# where {VAR} is the format string bitbake should look for in the
Brad Bishop5e329ba2016-08-17 12:08:16 -040023# file and VALUE is the value to substitute.
Brad Bishopf815b2e2016-07-14 19:50:19 -040024#
Brad Bishop58700d12016-08-15 22:35:58 -040025# SYSTEMD_USER_${PN}.service = "foo"
26# SYSTEMD_USER_${unit}.service = "foo"
27# The user for the unit/package.
Brad Bishopafb2e1b2016-08-08 09:29:20 -040028#
29# SYSTEMD_ENVIRONMENT_FILE_${PN} = "foo"
30# One or more environment files to be installed.
Brad Bishop51528fe2016-07-14 19:34:06 -040031
Brad Bishop9dc56712016-07-07 15:56:02 -040032
33inherit obmc-phosphor-utils
Brad Bishop93fb5352015-09-09 03:59:20 +000034inherit systemd
Brad Bishopf815b2e2016-07-14 19:50:19 -040035inherit useradd
Brad Bishop93fb5352015-09-09 03:59:20 +000036
Brad Bishop9dc56712016-07-07 15:56:02 -040037_INSTALL_SD_UNITS=""
Brad Bishop51528fe2016-07-14 19:34:06 -040038SYSTEMD_DEFAULT_TARGET ?= "obmc-standby.target"
Brad Bishopafb2e1b2016-08-08 09:29:20 -040039envfiledir ?= "${sysconfdir}/default"
Brad Bishop9dc56712016-07-07 15:56:02 -040040
Brad Bishopf815b2e2016-07-14 19:50:19 -040041# Big ugly hack to prevent useradd.bbclass post-parse sanity checker failure.
42# If there are users to be added, we'll add them in our post-parse.
43# If not...there don't seem to be any ill effects...
44USERADD_PACKAGES ?= " "
45USERADD_PARAM_${PN} ?= ";"
46
Brad Bishope36358c2016-06-08 22:03:59 -040047
Brad Bishop18645292016-08-16 08:18:07 -040048def SystemdUnit(unit):
49 class Unit(object):
50 def __init__(self, unit):
51 self.unit = unit
Brad Bishop687146f2016-07-11 13:05:26 -040052
Brad Bishop18645292016-08-16 08:18:07 -040053 def __getattr__(self, item):
54 if item is 'name':
55 return self.unit
56 if item is 'is_activated':
57 return self.unit.startswith('dbus-')
58 if item is 'is_template':
59 return '@.' in self.unit
60 if item is 'is_instance':
61 return '@' in self.unit and not self.is_template
62 if item in ['is_service', 'is_target']:
63 return self.unit.split('.')[-1] == item
64 if item is 'base':
65 cls = self.unit.split('.')[-1]
66 base = self.unit.replace('dbus-', '')
67 base = base.replace('.%s' % cls, '')
68 if self.is_instance:
69 base = base.rstrip('@%s' % self.instance)
70 if self.is_template:
71 base = base.rstrip('@')
72 return base
73 if item is 'instance' and self.is_instance:
74 inst = self.unit.rsplit('@')[-1]
75 return inst.rsplit('.')[0]
76 if item is 'template' and self.is_instance:
77 cls = self.unit.split('.')[-1]
78 return '%s@.%s' % (self.base, cls)
79 if item is 'template' and self.is_template:
80 return '.'.join(self.base.split('@')[:-1])
Brad Bishop687146f2016-07-11 13:05:26 -040081
Brad Bishop18645292016-08-16 08:18:07 -040082 raise AttributeError(item)
83 return Unit(unit)
Brad Bishop687146f2016-07-11 13:05:26 -040084
85
86def systemd_parse_unit(d, path):
87 import ConfigParser
88 parser = ConfigParser.SafeConfigParser()
89 parser.optionxform = str
90 parser.read('%s' % path)
91 return parser
92
93
Brad Bishope36358c2016-06-08 22:03:59 -040094python() {
Brad Bishop687146f2016-07-11 13:05:26 -040095 def check_sd_unit(d, unit):
Brad Bishop9dc56712016-07-07 15:56:02 -040096 searchpaths = d.getVar('FILESPATH', True)
Brad Bishop18645292016-08-16 08:18:07 -040097 path = bb.utils.which(searchpaths, '%s' % unit.name)
Brad Bishop9dc56712016-07-07 15:56:02 -040098 if not os.path.isfile(path):
Brad Bishop18645292016-08-16 08:18:07 -040099 bb.fatal('Did not find unit file "%s"' % unit.name)
Brad Bishop687146f2016-07-11 13:05:26 -0400100
101 parser = systemd_parse_unit(d, path)
102 inhibit = listvar_to_list(d, 'INHIBIT_SYSTEMD_RESTART_POLICY_WARNING')
Brad Bishop18645292016-08-16 08:18:07 -0400103 if unit.is_service and \
104 not unit.is_template and \
105 unit.name not in inhibit and \
Brad Bishop687146f2016-07-11 13:05:26 -0400106 not parser.has_option('Service', 'Restart'):
107 bb.warn('Systemd unit \'%s\' does not '
Brad Bishop18645292016-08-16 08:18:07 -0400108 'have a restart policy defined.' % unit.name)
Brad Bishop687146f2016-07-11 13:05:26 -0400109
110
Brad Bishop522234c2016-08-17 15:42:31 -0400111 def add_default_subs(d, file):
112 set_append(d, '_MAKE_SUBS', '%s' % file)
Brad Bishop687146f2016-07-11 13:05:26 -0400113
Brad Bishop51528fe2016-07-14 19:34:06 -0400114 for x in [
115 'base_bindir',
116 'bindir',
117 'sbindir',
Brad Bishopafb2e1b2016-08-08 09:29:20 -0400118 'envfiledir',
Brad Bishop51528fe2016-07-14 19:34:06 -0400119 'SYSTEMD_DEFAULT_TARGET' ]:
Brad Bishop522234c2016-08-17 15:42:31 -0400120 set_append(d, 'SYSTEMD_SUBSTITUTIONS_%s' % file,
Brad Bishop51528fe2016-07-14 19:34:06 -0400121 '%s:%s' % (x, d.getVar(x, True)))
122
Brad Bishopf815b2e2016-07-14 19:50:19 -0400123
Brad Bishop522234c2016-08-17 15:42:31 -0400124 def add_sd_unit(d, unit, pkg):
Brad Bishop18645292016-08-16 08:18:07 -0400125 name = unit.name
Brad Bishop522234c2016-08-17 15:42:31 -0400126 unit_dir = d.getVar('systemd_system_unitdir', True)
127 set_append(d, 'SRC_URI', 'file://%s' % name)
128 set_append(d, 'FILES_%s' % pkg, '%s/%s' % (unit_dir, name))
129 set_append(d, '_INSTALL_SD_UNITS', name)
130 add_default_subs(d, name)
131
132
133 def add_sd_user(d, file, pkg):
Brad Bishopf815b2e2016-07-14 19:50:19 -0400134 opts = [
135 '--system',
136 '--home',
137 '/',
138 '--no-create-home',
139 '--shell /sbin/nologin',
140 '--user-group']
141
Brad Bishop522234c2016-08-17 15:42:31 -0400142 var = 'SYSTEMD_USER_%s' % file
Brad Bishop58700d12016-08-15 22:35:58 -0400143 user = listvar_to_list(d, var)
144 if len(user) is 0:
145 var = 'SYSTEMD_USER_%s' % pkg
146 user = listvar_to_list(d, var)
147 if len(user) is not 0:
148 if len(user) is not 1:
149 bb.fatal('Too many users assigned to %s: \'%s\'' % (var, ' '.join(user)))
150
151 user = user[0]
Brad Bishop522234c2016-08-17 15:42:31 -0400152 set_append(d, 'SYSTEMD_SUBSTITUTIONS_%s' % file,
Brad Bishop58700d12016-08-15 22:35:58 -0400153 'USER:%s' % user)
154 if user not in d.getVar('USERADD_PARAM_%s' % pkg, True):
155 set_append(
156 d,
157 'USERADD_PARAM_%s' % pkg,
158 '%s' % (' '.join(opts + [user])),
159 ';')
Brad Bishopf815b2e2016-07-14 19:50:19 -0400160 if pkg not in d.getVar('USERADD_PACKAGES', True):
161 set_append(d, 'USERADD_PACKAGES', pkg)
162
Brad Bishop9dc56712016-07-07 15:56:02 -0400163
Brad Bishopafb2e1b2016-08-08 09:29:20 -0400164 def add_env_file(d, name, pkg):
165 set_append(d, 'SRC_URI', 'file://%s' % name)
166 set_append(d, 'FILES_%s' % pkg, '%s/%s' \
167 % (d.getVar('envfiledir', True), name))
168 set_append(d, '_INSTALL_ENV_FILES', name)
169
170
Brad Bishop62d676a2016-07-11 00:42:58 -0400171 pn = d.getVar('PN', True)
Brad Bishop9dc56712016-07-07 15:56:02 -0400172 if d.getVar('SYSTEMD_SERVICE_%s' % pn, True) is None:
173 d.setVar('SYSTEMD_SERVICE_%s' % pn, '%s.service' % pn)
Brad Bishope36358c2016-06-08 22:03:59 -0400174
Brad Bishop9dc56712016-07-07 15:56:02 -0400175 for pkg in listvar_to_list(d, 'SYSTEMD_PACKAGES'):
Brad Bishop18645292016-08-16 08:18:07 -0400176 svc = listvar_to_list(d, 'SYSTEMD_SERVICE_%s' % pkg)
177 svc = [SystemdUnit(x) for x in svc]
178 tmpl = [x.template for x in svc if x.is_instance]
179 tmpl = list(set(tmpl))
180 tmpl = [SystemdUnit(x) for x in tmpl]
181 svc = [x for x in svc if not x.is_instance]
182
183 for unit in tmpl + svc:
Brad Bishop687146f2016-07-11 13:05:26 -0400184 check_sd_unit(d, unit)
Brad Bishop9dc56712016-07-07 15:56:02 -0400185 add_sd_unit(d, unit, pkg)
Brad Bishop522234c2016-08-17 15:42:31 -0400186 add_sd_user(d, unit.name, pkg)
Brad Bishopafb2e1b2016-08-08 09:29:20 -0400187 for name in listvar_to_list(d, 'SYSTEMD_ENVIRONMENT_FILE_%s' % pkg):
188 add_env_file(d, name, pkg)
Brad Bishope36358c2016-06-08 22:03:59 -0400189}
Brad Bishop93fb5352015-09-09 03:59:20 +0000190
Brad Bishop9dc56712016-07-07 15:56:02 -0400191
Brad Bishop51528fe2016-07-14 19:34:06 -0400192python systemd_do_postinst() {
Brad Bishop522234c2016-08-17 15:42:31 -0400193 def make_subs(d):
194 for f in listvar_to_list(d, '_MAKE_SUBS'):
195 subs = dict([ x.split(':') for x in
196 listvar_to_list(d, 'SYSTEMD_SUBSTITUTIONS_%s' % f)])
197 if not subs:
198 continue
Brad Bishop51528fe2016-07-14 19:34:06 -0400199
Brad Bishop522234c2016-08-17 15:42:31 -0400200 path = d.getVar('D', True)
201 path += d.getVar('systemd_system_unitdir', True)
202 path += '/%s' % f
203 with open(path, 'r') as fd:
204 content = fd.read()
205 with open(path, 'w+') as fd:
206 try:
207 fd.write(content.format(**subs))
208 except KeyError as e:
209 bb.fatal('No substitution found for %s in '
210 'file \'%s\'' % (e, f))
211
212
Brad Bishopafb2e1b2016-08-08 09:29:20 -0400213 def install_envs(d):
214 install_dir = d.getVar('D', True)
215 install_dir += d.getVar('envfiledir', True)
216 searchpaths = d.getVar('FILESPATH', True)
217
218 for f in listvar_to_list(d, '_INSTALL_ENV_FILES'):
219 src = bb.utils.which(searchpaths, f)
220 if not os.path.isfile(src):
221 bb.fatal('Did not find SYSTEMD_ENVIRONMENT_FILE:'
222 '\'%s\'' % src)
223
224 dest = os.path.join(install_dir, f)
225 parent = os.path.dirname(dest)
226 if not os.path.exists(parent):
227 os.makedirs(parent)
228
229 with open(src, 'r') as fd:
230 content = fd.read()
231 with open(dest, 'w+') as fd:
232 fd.write(content)
233
234
235 install_envs(d)
Brad Bishop522234c2016-08-17 15:42:31 -0400236 make_subs(d)
Brad Bishop51528fe2016-07-14 19:34:06 -0400237}
238
239
Brad Bishop93fb5352015-09-09 03:59:20 +0000240do_install_append() {
Brad Bishope36358c2016-06-08 22:03:59 -0400241 # install systemd service/socket/template files
Brad Bishop9dc56712016-07-07 15:56:02 -0400242 [ -z "${_INSTALL_SD_UNITS}" ] || \
Brad Bishope36358c2016-06-08 22:03:59 -0400243 install -d ${D}${systemd_system_unitdir}
Brad Bishop9dc56712016-07-07 15:56:02 -0400244 for s in ${_INSTALL_SD_UNITS}; do
245 install -m 0644 ${WORKDIR}/$s \
246 ${D}${systemd_system_unitdir}/$s
Brad Bishope36358c2016-06-08 22:03:59 -0400247 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
248 -e 's,@BINDIR@,${bindir},g' \
249 -e 's,@SBINDIR@,${sbindir},g' \
250 ${D}${systemd_system_unitdir}/$s
251 done
Brad Bishop93fb5352015-09-09 03:59:20 +0000252}
Brad Bishop51528fe2016-07-14 19:34:06 -0400253
254
255do_install[postfuncs] += "systemd_do_postinst"