blob: 636fb35811bac623709632c7225bf4b46afb020c [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "Python Jinja2: A small but fast and easy to use stand-alone template engine written in pure python."
Patrick Williamsde0582f2022-04-08 10:23:27 -05002HOMEPAGE = "https://pypi.org/project/Jinja2/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
6
Patrick Williams56b44a92024-01-19 08:49:29 -06007SRC_URI[sha256sum] = "ac8bd6544d4bb2c9792bf3a159e80bba8fda7f07e81bc3aed565432d5925ba90"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008
9PYPI_PACKAGE = "Jinja2"
10
11CVE_PRODUCT = "jinja2 jinja"
12
13CLEANBROKEN = "1"
14
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050015inherit pypi setuptools3 ptest
Andrew Geissler9aee5002022-03-30 16:27:02 +000016
17SRC_URI += " \
18 file://run-ptest \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
25
26RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060027 python3-pytest \
28 python3-unittest-automake-output \
29 python3-toml \
30 python3-unixadmin \
Andrew Geissler9aee5002022-03-30 16:27:02 +000031"
32
33RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060034 python3-asyncio \
35 python3-crypt \
36 python3-io \
37 python3-json \
38 python3-markupsafe \
39 python3-math \
40 python3-netclient \
41 python3-numbers\
42 python3-pickle \
43 python3-pprint \
44 python3-shell \
45 python3-threading \
Andrew Geissler9aee5002022-03-30 16:27:02 +000046"
47
48BBCLASSEXTEND = "native nativesdk"