blob: a5d722fda8f677f7ddb3ffd9d3bc5ff085452601 [file] [log] [blame]
John Wanga66aa8a2020-09-30 13:19:08 +08001FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2OBMC_CONSOLE_HOST_TTY = "ttyS2"
3SRC_URI += "file://obmc-console@.service \
4 "
5inherit obmc-phosphor-systemd
6
7SYSTEMD_SERVICE_${PN} += " \
8 ${PN}@${OBMC_CONSOLE_HOST_TTY}.service \
9 "
10
11do_install_append() {
12 rm -rf ${D}${base_libdir}/udev/rules.d/80-obmc-console-uart.rules
13 install -m 0644 ${WORKDIR}/${PN}@.service ${D}${systemd_system_unitdir}
14}