blob: 1ec34e73729ec6eeb128410e5087e50d6e85d349 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Freetype font rendering library"
2DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3highly customizable, and portable while capable of producing high-quality output (glyph \
4images). It can be used in graphics libraries, display servers, font conversion tools, text \
5image generation tools, and many other products as well."
6HOMEPAGE = "http://www.freetype.org/"
7BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8SECTION = "libs"
9
10LICENSE = "FreeType | GPLv2+"
Patrick Williams213cb262021-08-07 19:21:33 -050011LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=a5927784d823d443c6cae55701d01553 \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012 file://docs/FTL.TXT;md5=9f37b4e6afa3fef9dba8932b16bd3f97 \
13 file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
14
Brad Bishop96ff1982019-08-19 13:50:42 -040015SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/${BPN}/${BP}.tar.xz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016 file://use-right-libtool.patch \
17 "
Patrick Williams213cb262021-08-07 19:21:33 -050018SRC_URI[sha256sum] = "8bee39bd3968c4804b70614a0a3ad597299ad0e824bc8aad5ce8aaf48067bde7"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020UPSTREAM_CHECK_REGEX = "freetype-(?P<pver>\d+(\.\d+)+)"
21
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022inherit autotools pkgconfig multilib_header
23
24# Adapt autotools to work with the minimal autoconf usage in freetype
25AUTOTOOLS_SCRIPT_PATH = "${S}/builds/unix"
26CONFIGURE_SCRIPT = "${S}/configure"
27EXTRA_AUTORECONF += "--exclude=autoheader --exclude=automake"
28
Andrew Geissler82c905d2020-04-13 13:39:40 -050029PACKAGECONFIG ??= "zlib pixmap"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030
31PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
32# harfbuzz results in a circular dependency so enabling is non-trivial
33PACKAGECONFIG[harfbuzz] = "--with-harfbuzz,--without-harfbuzz,harfbuzz"
34PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
35PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
36PACKAGECONFIG[freetypeconfig] = "--enable-freetype-config=yes,--enable-freetype-config=no,"
37
38EXTRA_OECONF = "CC_BUILD='${BUILD_CC}'"
39
40TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
41
Patrick Williams213cb262021-08-07 19:21:33 -050042do_install:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080043 oe_multilib_header freetype2/freetype/config/ftconfig.h
44}
45
46BBCLASSEXTEND = "native nativesdk"