blob: 77f4be7dbeeb3893ecb6798e096292b346a58e66 [file] [log] [blame]
Karthikeyan Pasupathi36f035b2022-08-28 17:35:29 +05301FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3DEFAULT_TARGETS = " \
4 multi-user.target.requires/obmc-host-reset@{}.target \
5 obmc-chassis-poweron@{}.target.wants/chassis-poweron@{}.service \
6 obmc-chassis-hard-poweroff@{}.target.wants/chassis-poweroff@{}.service \
7 obmc-host-shutdown@{}.target.wants/host-poweroff@{}.service \
8 obmc-host-start@{}.target.wants/host-poweron@{}.service \
9 obmc-host-reboot@{}.target.wants/host-powercycle@{}.service \
10"
11
12SRC_URI:append:greatlakes = " \
13 file://chassis-poweroff@.service \
14 file://chassis-poweron@.service \
15 file://host-poweroff@.service \
16 file://host-poweron@.service \
17 file://host-powercycle@.service \
18 file://chassis-poweroff \
19 file://chassis-poweron \
20 file://host-poweroff \
21 file://host-poweron \
22 file://host-powercycle \
23 file://power-cmd \
24 "
25
26RDEPENDS:${PN}:append:greatlakes = " bash"
27
28do_install:append:greatlakes() {
29 install -d ${D}${systemd_system_unitdir}
30 install -m 0644 ${WORKDIR}/*.service ${D}${systemd_system_unitdir}/
31
32 install -d ${D}${libexecdir}
33 install -m 0777 ${WORKDIR}/chassis-poweroff ${D}${libexecdir}/
34 install -m 0777 ${WORKDIR}/chassis-poweron ${D}${libexecdir}/
35 install -m 0777 ${WORKDIR}/host-poweroff ${D}${libexecdir}/
36 install -m 0777 ${WORKDIR}/host-poweron ${D}${libexecdir}/
37 install -m 0777 ${WORKDIR}/host-powercycle ${D}${libexecdir}/
38 install -m 0777 ${WORKDIR}/power-cmd ${D}${libexecdir}/
39}
40FILES:${PN} += " /lib/systemd/system/*.service"