blob: 0f957970f230b49fcbf02995056ba8a1ec98ee67 [file] [log] [blame]
Patrick Venture998ff012018-03-09 15:37:45 -08001SUMMARY = "Phosphor PID Fan Control"
2DESCRIPTION = "Fan Control"
Patrick Ventureffad0482018-09-29 09:19:22 -07003HOMEPAGE = "github.com/openbmc/phosphor-pid-control"
Patrick Venture998ff012018-03-09 15:37:45 -08004PR = "r1"
Patrick Ventureffad0482018-09-29 09:19:22 -07005PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture998ff012018-03-09 15:37:45 -08008
James Feist03bea902018-11-20 11:29:16 -08009inherit flto-automake pkgconfig
Patrick Venture998ff012018-03-09 15:37:45 -080010
11inherit phosphor-pid-control
12inherit obmc-phosphor-ipmiprovider-symlink
Vijay Khemka09ad25b2019-06-20 14:37:11 -070013inherit systemd
Patrick Venture998ff012018-03-09 15:37:45 -080014
Patrick Ventureffad0482018-09-29 09:19:22 -070015S = "${WORKDIR}/git"
16SRC_URI = "git://github.com/openbmc/phosphor-pid-control"
Vijay Khemka09ad25b2019-06-20 14:37:11 -070017SRCREV = "e7f4a5d5c93b8ee7e91351c6f7c3e66f03cb40f5"
Patrick Ventureffad0482018-09-29 09:19:22 -070018
Patrick Venture998ff012018-03-09 15:37:45 -080019# Each platform will need a service file that starts
20# at an appropriate time per system. For instance, if
21# your system relies on passive dbus for fans or other
22# sensors then it may be prudent to wait for all of them.
23
24DEPENDS += "autoconf-archive-native"
Patrick Venture998ff012018-03-09 15:37:45 -080025DEPENDS += "sdbusplus"
Brad Bishop44f3cce2019-03-22 23:41:42 -040026DEPENDS += "phosphor-dbus-interfaces"
Patrick Venture998ff012018-03-09 15:37:45 -080027DEPENDS += "phosphor-logging"
28DEPENDS += "libevdev"
Patrick Venture4686bb52019-02-12 08:59:31 -080029DEPENDS += "nlohmann-json"
Patrick Venture0647c292019-03-11 08:45:12 -070030DEPENDS += "cli11"
Andrew Geissler3f2554c2019-04-15 14:22:02 +000031DEPENDS += "boost"
Patrick Venture998ff012018-03-09 15:37:45 -080032
Patrick Venture998ff012018-03-09 15:37:45 -080033# We depend on this to be built first so we can build our providers.
34DEPENDS += "phosphor-ipmi-host"
35
Vijay Khemka09ad25b2019-06-20 14:37:11 -070036SERVICE_FILE = "phosphor-pid-control.service"
37SYSTEMD_PACKAGES = "${PN}"
38SYSTEMD_SERVICE_${PN} = "${SERVICE_FILE}"
39
40EXTRA_OECONF = " \
41 SYSTEMD_TARGET="multi-user.target" \
42 "
43
Andrew Geissler00506842019-03-29 16:11:53 +000044FILES_${PN} = "${bindir}/swampd ${bindir}/setsensor"
Patrick Venture998ff012018-03-09 15:37:45 -080045
Patrick Venture26f8c6c2018-07-27 07:27:01 -070046# The following installs the OEM IPMI handler for the fan controls.
47FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
48FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
49FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
50FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Patrick Venture998ff012018-03-09 15:37:45 -080051
Patrick Venture26f8c6c2018-07-27 07:27:01 -070052HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so"