blob: 1efe2ea216e9d5e0b2c8893d2872ca089d2964c3 [file] [log] [blame]
Deepak Kodihalli75c32cc2017-02-05 10:39:06 -06001SUMMARY = "Parser for OpenPOWER-format FRU VPD"
2DESCRIPTION = "Parse OpenPOWER-format FRU VPD and update inventory"
3PR = "r1"
4
5inherit autotools pkgconfig
6inherit openpower-fru-vpd
7inherit pythonnative
8inherit obmc-phosphor-systemd
9
10require ${PN}.inc
11
Deepak Kodihalli09fb6242017-02-15 04:48:20 -060012SRC_URI += "file://70-op-vpd.rules"
13
Deepak Kodihalli75c32cc2017-02-05 10:39:06 -060014DEPENDS += " \
15 virtual/openpower-fru-vpd-layout \
16 virtual/openpower-fru-inventory \
17 sdbusplus \
18 phosphor-logging \
19 python-mako-native \
20 python-pyyaml-native \
21 autoconf-archive-native \
22 "
23
24RDEPENDS_${PN} += " \
25 sdbusplus \
26 phosphor-logging \
27 "
28
29SYSTEMD_SERVICE_${PN} += "op-vpd-parser.service"
30
31S = "${WORKDIR}/git"
32
33EXTRA_OECONF = "FRU_YAML=${STAGING_DIR_NATIVE}${vpdlayout_datadir}/layout.yaml"
34
35do_install_append() {
36 SRC=${STAGING_DATADIR_NATIVE}${inventory_datadir_name}
37 DEST=${D}${inventory_envdir}
38 install -d ${DEST}
39 install ${SRC}/inventory ${DEST}
Deepak Kodihalli09fb6242017-02-15 04:48:20 -060040
41 install -d ${D}/${base_libdir}/udev/rules.d/
42 install ${WORKDIR}/70-op-vpd.rules ${D}/${base_libdir}/udev/rules.d/
Deepak Kodihalli75c32cc2017-02-05 10:39:06 -060043}